Whats the correct repository for Ubuntu 13.10 64-bit with CUDA 5.5

Hi, am new to CUDA…have got to the bit in the ‘Getting started guide for Linux’ where it describes the Package Manager Installation for Ubuntu and tells me to:
sudo dpkg -i cuda-repo-.deb

I guessed the following, and various varients thereof…
sudo dpkg -i cuda-repo-ubuntu1310_5.5-0_x86_64.deb
…none of which it can find.

I’m running Ubuntu 13.10 64-bit and trying to download CUDA 5.5.

What is the correct and please?

Thank you.

You’ll need to download one of the cuda-repo .deb packages from https://developer.nvidia.com/cuda-downloads. CUDA 5.5 supports Ubuntu 12.04 and Ubuntu 12.10 in the .deb format, so you’ll have to pick one of those.

Thank you Andy.

Ok, please forgive my ignorance again…
I downloaded the .deb for ubunutu 12.10 into Ubunutu Software Centre, then ran…

sudo apt-get update
ok then…

sudo apt-get install cuda
Reading package lists… Done
Building dependency tree
Reading state information… Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies.
cuda : Depends: cuda-5-5 (= 5.5-22) but it is not going to be installed
E: Unable to correct problems, you have held broken packages.

Is this anything to do with needing to have uninstalled the NVIDIA driver first? cos I previously tried

/usr/bin/nvidia-uninstall and got…
bash: /usr/bin/nvidia-uninstall: No such file or directory

Appreciate your help.

Any suggestions on this please?

Can you try running:
apt-get install cuda-5-5

It should produce a similar message, except with different packages saying that they have unmet dependencies. For example, if it then says:
The following packages have unmet dependencies.
cuda-5-5 : Depends: cuda-samples-5-5 (= 5.5-22) but it is not going to be installed
E: Unable to correct problems, you have held broken packages.

Then try installing cuda-samples-5-5. By continuing this approach, we should end up with the package which truly does have broken dependencies.

Thank you Andy. I tried: ‘apt-get install cuda-5-5’ and got:

cuda-5-5 : Depends: nvidia-current (>= 319.00) but it is not going to be installed
Depends: nvidia-current-dev (>= 319.00) but it is not going to be installed

so I tried: ‘apt-get install nvidia-current’ and got:

nvidia-current : Depends: xorg-video-abi-11 but it is not installable or
xorg-video-abi-12 but it is not installable or
xorg-video-abi-13 but it is not installable
Recommends: nvidia-settings-current but it is not installable

so I tried: ‘apt-get install xorg-video-abi-11’ and got:

Package xorg-video-abi-11 is not available

so, looking at the advice on various postings, I also tried installing xorg-server-lts-quantal and xserver-xorg-core-lts-quantal and intel-linux-graphics-installer and xserver-xorg-core and xorg-server

None of which it could find.

Sorry, I’m stuck again - would appreciate any help you can provide.

Instead of trying to install the .deb file, just try these instructions I did a few weeks ago to install the .run file:
http://pastebin.com/fDpqvSi5

Those take care of installing the latest nvidia-331 drivers from xorg-edgers as well as configuring the build environment and installing the CUDA .run file appropriately. They should work on any recent Ubuntu distro: 12.04.3, 12.10, 13.04 and 13.10.

Wow. This worked perfectly. There is no WAY I would have worked this out on my own. Thank you so much vacaloca - really appreciated. Your instructions were crystal clear. Thank you.

Glad it helped :)

I followed these instructions, but didn’t get the same result. The cuda installer reports this:

= Summary =

Driver: Not Selected
Toolkit: Installed in /usr/local/cuda-5.5
Samples: Installed in /opt/cuda_samples

  • Please make sure your PATH includes /usr/local/cuda-5.5/bin

  • Please make sure your LD_LIBRARY_PATH

  • for 32-bit Linux distributions includes /usr/local/cuda-5.5/lib

  • for 64-bit Linux distributions includes /usr/local/cuda-5.5/lib64:/lib

  • OR

  • for 32-bit Linux distributions add /usr/local/cuda-5.5/lib

  • for 64-bit Linux distributions add /usr/local/cuda-5.5/lib64 and /lib

  • to /etc/ld.so.conf and run ldconfig as root

  • To uninstall CUDA, remove the CUDA files in /usr/local/cuda-5.5

  • Installation Complete

Please see CUDA_Getting_Started_Linux.pdf in /usr/local/cuda-5.5/doc/pdf for detailed information on setting up CUDA.

***WARNING: Incomplete installation! This installation did not install the CUDA Driver. A driver of version at least 319.00 is required for CUDA 5.5 functionality to work.
To install the driver using this installer, run the following command, replacing with the name of this run file:
sudo .run -silent -driver

nvidia-settings confirms that I’m using the 331.20 driver. Any ideas?

Thanks so much for this vacaloca

@dlauer: Your setup is most likely fine… the CUDA installer just reports it didn’t install the driver that it came with… which is older. The fact that “nvidia-settings confirms that I’m using the 331.20 driver” means you should be all set :)

Glad this has helped others!