When I added the following contents, the device was repeatedly booted in the boot logo, and the system could not be accessed

Dear all:

  1. Jetpack4.6_R32.6.1, jetson tx2 nx SOM in our custom board.

  2. After add following content in tegra186-p3636-0001-common.dtsi file, device get wrong.
    Continuing the discussion from TX2 NX SPI pinmux setting on R32.6.1 error:

+       pinmux@2430000 {
+               pinctrl-0 = <0x179>;
+               pinctrl-names = "default";
+               compatible = "nvidia,tegra194-pinmux";
+               reg = <0x0 0x2430000 0x0 0x17000 0x0 0xc300000 0x0 0x4000>;
+               #gpio-range-cells = <0x3>;
+               status = "okay";
+               linux,phandle = <0xab>;
+               phandle = <0xab>;
+
+               header-40pin-pinmux {
+                       phandle = <0x179>;
+                       linux,phandle = <0x179>;
+
+                       pin24 {
+                               nvidia,lpdr = <0x0>;
+                               nvidia,enable-input = <0x1>;
+                               nvidia,tristate = <0x0>;
+                               nvidia,pull = <0x2>;
+                               nvidia,pins = "spi1_cs0_pz6";
+                               nvidia,function = "spi1";
+                       };
+
+                       pin23 {
+                               nvidia,lpdr = <0x0>;
+                               nvidia,enable-input = <0x1>;
+                               nvidia,tristate = <0x0>;
+                               nvidia,pull = <0x1>;
+                               nvidia,pins = "spi1_sck_pz3";
+                               nvidia,function = "spi1";
+                       };
+
+                       pin21 {
+                               nvidia,lpdr = <0x0>;
+                               nvidia,enable-input = <0x1>;
+                               nvidia,tristate = <0x0>;
+                               nvidia,pull = <0x1>;
+                               nvidia,pins = "spi1_miso_pz4";
+                               nvidia,function = "spi1";
+                       };
+
+                       pin19 {
+                               nvidia,lpdr = <0x0>;
+                               nvidia,enable-input = <0x1>;
+                               nvidia,tristate = <0x0>;
+                               nvidia,pull = <0x1>;
+                               nvidia,pins = "spi1_mosi_pz5";
+                               nvidia,function = "spi1";
+                       };
+
+               };
+       };


+       can_clock: can_clock {
+               compatible = "fixed-clock";
+               #clock-cells = <0>;
+               clock-frequency = <8000000>;
+               clock-accuracy = <100>;
+       };
+
        spi@3210000 { /* SPI 1 to 40 pin header */
                status = "okay";
                spi@0 {
-                       compatible = "tegra-spidev";
+                       compatible = "microchip,mcp2515";
                        reg = <0x0>;
-                       spi-max-frequency = <33000000>;
+                        spi-max-frequency = <5000000>;
+                        clocks = <&can_clock>;
+                        interrupt-parent = <&tegra_main_gpio>;
+                       interrupts = <&tegra_main_gpio TEGRA_MAIN_GPIO(N, 1) GPIO_ACTIVE_HIGH>;
                        controller-data {
                                nvidia,enable-hw-based-cs;
                                nvidia,rx-clk-tap-delay = <0x8>;

You may need UART log to check the kernel message to know the root cause.

After change tegra186-mb1-bct-pinmux-p3636-0001-a00.cfg as following, i can see can1. but can1 only can receive ,can not send data.


this is dmesg follow, gpio set failed.
1667985760241

What’s the pin 22/23? Doesn’t see your dts change relative with GPIO.

sudo /opt/nvidia/jetson-io/jetson-io.py , this gpio is define by nvidia.
1668062799207

Did you add those SPI pin configuration manually or that’s generate from jetson-io?

Thanks

I change this pinmux in following picture.

Please use jetson-io to configure the PINs for TX2 NX

Thanks

After execute sudo /opt/nvidia/jetson-io/jetson-io.py and enable spi1, device can not enter system , just restart in boot logo.

OK, will try if able catch the problem like you do.

Thanks

There is a known issue in cboot that may cause jetson IO fails to take effect.

I change cboot.bin, but it can not resolv problem.

Please try with the latest JetPack 4.6.3?

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.