When I boot jetpack os to my jetson nano, there are always some broken internal packages

When I try to install anything that matters to run code (thonny, etc), I get many errors. I flash the same is using same flasher (rufus) and different internal packages are broken each time. It’s like a slot machine of errors.

Hi, please attach the error log here (as text, not image).
We cannot help you with such vague information.
Also, to make sure, you are using a Jetson Nano board right?
What version of L4T is installed? The latest r32.7.3?

Here’s the errorE: Sub-process /usr/bin/dpkg returned an error code (2)L4T is R32 revision 7.1

Try this post and see if it helps:

Did you fail to install any packages with APT before getting these errors and after doing a whole re-flash?

I tried that but trying sudo apt-get install python-pip returns the same error. Also, what do you mean “doing a whole-reflash”?

Can you follow this guide:
, or use SDK Manager to flash your device?

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.