When will the CreateXR be supported on Linux?

Hi. Please share the launching/development plans if there is CreateXR support for Linux. Thanks!

Hello @PARKBONG! I show that XR is supported on Ubuntu. Have you tried using it with Ubuntu? Did you run into any issues?

Oh, It tried to run it on the Linux, and I checked It works.


How did you managed to install it on linux. I have the same problem you had before you edited your comment.

And running the isaac_sim in VR causes a crash

Hi, @09ubberboy90,
In my case, I just launched ./issac-sim.xr.steamvr.sh

And I’m sorry that I have no idea about crash issue…

Thanks for the help. Did you manage to run in VR from that windows. For me it launches fine but as soon as I press start VR it crashes. Is it the same for you ?

If not can you give me your driver version and what Linux you are running ?

Thank you

Hi, @09ubberboy90,

  1. I found that there are 2 ways to launch isaacsim + VR window.
  • $ bash ./issac-sim.xr.steamvr.sh
  • launch isaacsim - windows - extensions - enable omni.issacsim.xr.steamvr with autoload
  1. actually, I have same problems with you, In my case,
    After hitting the start VR button, It works only after 1 seconds, and isaacsim stop working. It usually make my whole ubuntu kernels stop.

I tested it on the 2 computers with 3070Ti and A6000 graphic cards.

can you share your detailed CLI log? I guess we need to compare the log to find out the problem if it comes from our local or isaacsim code itself.


If you are OK, please send me email, iampbk7@gmail.com

I really need to setup HMD with isaacsim.
maybe we can debate more detailed settings or issues. thanks.

Just to make it fair to the forum. I’ve reported this problem Unable to start in VR - #3 by Hammad_M

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.