Where does nvpmodel save its information?


I am trying to fetch the information of the nvpmodel from inside the docker and when i run initially after starting my docker ‘nvpmodel -q’ it throws NVPM ERROR: power mode is not set!, but when I set a mode inside my docker then it is able to recognize the mode it is present in. What could be the reason for this action. I guess i miss to mount some files. Does anyone have clear idea about this?.

Do you have a file /etc/nvpmodel.conf?

If that isn’t in place I’d also check if this shows files in place:

sha1sum -c /etc/nv_tegra_release

Yes I do have that, but I believe that file is the configuration of the modes that we select.

Hello @linuxdev, I have all the listed files mounted on the docker. I observed these things.

  1. First thing as I reported, I don't find the the current nvpmodel configuration inside the docker
  2. Second, once I set the mode in docker, I could clearly see that it works with tegrastats, however, the query of 'nvpmodel -q' outside the docker has not changed.

This is clear that I am missing to mount a file, but I am not sure which file it is.

How about this one?


Bravo, Perfect this is the one I have been looking for. This solved the issue. Thank you so much.