Where is the settings app located in Jetson nano 2gb?

Hey, I am trying to change the default mic on my Jetson Nano 2GB developer kit, but I am unable to find the settings app. Can someone please tell me how to change the default mic?

What kind of mic device you connected on Nano?
Via I2S or USB?

Hi, I am using a USB mic

Hi,
Please execute $ arecord -l and check the list. The command lists all audio recording devices.

I ran the command, and its showing that the mic is in card 2. Do you want the full output? i can copy it here if you do.

Hi,
You can try arecord command like:

$ arecord -D hw:2,0 -c2 -d 10 -r 44100 -f S16_LE a.wav

hw:2,0 means card 2, device 0

1 Like

I ran the command, and this was the output:

Recording WAVE 'a.wav' : Signed 16 bit Little Endian, Rate 44100 Hz, Stereo
arecord: set_params:1305: Channels count non available

Can you tell me what to do next?

Hi,
Probably it supports single channel only. Please try -c 1

Hi @DaneLLL , I ran the command arecord -D hw:2,0 -c1 -d 10 -r 44100 -f S16_LE a.wav just like you suggested, and this was the output:

Recording WAVE 'a.wav' : Signed 16 bit Little Endian, Rate 44100 Hz, Mono
Warning: rate is not accurate (requested = 44100Hz, got = 48000Hz)
         please, try the plug plugin 

This was the output, please tell me what to do next

Hi,
Please try -r 48000. Seems like the mix does not support 44.1kHz.

Hi,
I tried it with -r 48000, and got this result:

Recording WAVE 'a.wav' : Signed 16 bit Little Endian, Rate 48000 Hz, Mono

btw @DaneLLL , what does this command do? just asking to learn lol, and also. the default mic is still unchanged even tho I input the correct frequency.

sorry if these doubts were stupid im a newbie to linux

Hi,
It is to record audio for 10 seconds. If it can be run successfully, you should see a.wav is saved.

hi, i am unable to find where a.wav is located, can you please help me with that?

Hi,
You can save it to /tmp/:

$ arecord -D hw:2,0 -c1 -d 10 -r 48000 -f S16_LE /tmp/a.wav

And run $ ls /tmp/ to check if it is saved.

Hey,
So the a.wav file is saved now and the audio is working fine, but is the mic now my default mic?

Edit: So i just checked, and it its’t the default mic. I only think the command records audio. can you please suggest a way to set the default mic now, the recording works really good though!

Hi,
This would need other users to share experience. There should be a GUI similar to Windows control panel and you can configure the audio input device.

Hi,
I searched so much for the “windows control panel” in jetson nano, but I couldn’t find anything that relates to audio settings/changing the default mic. Do you happen to know its location?