Which driver version is best for X86_64?

(Sorry, forgot it in the topic title, but this is for Linux.)

With 190.53 (actually, it may have been 190.29) GL_INTEROP wouldn’t work, so I upgraded to beta 195.30, which was the newest I could find for the X86_64 platform, but now not even the SDK samples won’t work. (They barf at the cxGPUContext = clCreateContextFromType(NULL, CL_DEVICE_TYPE_GPU, NULL, NULL, &ciErrNum) with error message

!!! Error # -32 at line 185 , in file test1.cpp !!!

where test1.cpp is just my copy of oclSimpleGL.cpp. I find it a bit odd that this does not work, so I suspect I might have done something else wrong… But not sure what… Is there a SDK or a toolkit tightly linked to each version of the driver, so that I should reinstall these also??

All ideas appreciated…

N.

195.36.08

http://forums.nvidia.com/index.php?showtop…t=#entry1016026

I tried 190.53 and I could not compile due to missing OpenCL files. The I tried 195.30 and got the same error as you. So I reverted back to 195.17 from a file called cudadriver_3.0-beta1_linux_64_195.17-beta.run. Do you need special drivers to work with CUDA and OpenCL or will all the display drivers work?

Should we use cuda 3.0beta1 or 2.3?

You pretty much have two options and I’ve managed to get each of these compiling and working in various configurations/flavors:

  1. Use the official OpenCL release from NVIDIA (http://developer.nvidia.com/object/opencl-download.html)
    Driver version 190.89 (Windows) and 190.29 (Linux) should work along with GPU SDK 2.3a

  2. Use the drivers and sdk that go with the CUDA 3.0 Beta (http://forums.nvidia.com/index.php?showtopic=149959)
    Driver version 195 and up have a different way of calling OpenCL commands, so the latest drivers require the 3.0 beta SDK.

The way of doing certain things and the libraries are a bit different from 2.3 to 3.0. I’ve personally found 3.0 to be faster and also, it should be the SDK moving forward. However, since the SDK is not compatible with the older drivers, you have to pick one and stick with it. There are threads discussing this all over this forum, do a bit of searching.

Thanks! This pretty much clears it up then. I went back to 190.29 + SDK 2.3a, and stuff works again. But not with “gl-interop”, unfortunately. I guess that it is an added benefit of moving to >=195 + the 3.0 CUDA Beta that this will work. (Haven’t actually checked yet, but will.) I suppose also I should have searched the forum better, but in my defense, I really tried to search (and grok) the NVIDIA-web site. I have to agree with one chap that wrote someplace that the NVIDIA website is both buggy, illogical and messy wrt. structure…

I personally like this forum in terms of structure, but to each his own. With compile errors that are not OpenCL specific, especially makefile builds, its better to google it with the exact phrase, because chances are, you’re just missing some libraries (especially in linux) and someone else has had the same problem before and solved it. These answers someone end up on the specific OS distribution sites and not here.

Yeah, googling is often the best method. I like the forum btw., what I had in mind was the non-forum web site of Nvidia…

N.