which Kubernetes's version is Suitable?

When I install clara deploy SDK according to the document,

sudo ./install-prereqs.sh

It seems a error due to Kubernetes’s version because it stops at

2019-11-27 01:58:32 [INFO]: Deploy kubernetes pod network.
clusterrole.rbac.authorization.k8s.io/flannel created
clusterrolebinding.rbac.authorization.k8s.io/flannel created
serviceaccount/flannel created
configmap/kube-flannel-cfg created
unable to recognize ".../scripts/kube-flannel.yml": no matches for kind "PodSecurityPolicy" in version "extensions/v1beta1"
unable to recognize ".../Downloads/scripts/kube-flannel.yml": no matches for kind "DaemonSet" in version "extensions/v1beta1"
unable to recognize ".../Downloads/scripts/kube-flannel.yml": no matches for kind "DaemonSet" in version "extensions/v1beta1"
unable to recognize ".../Downloads/scripts/kube-flannel.yml": no matches for kind "DaemonSet" in version "extensions/v1beta1"
unable to recognize ".../Downloads/scripts/kube-flannel.yml": no matches for kind "DaemonSet" in version "extensions/v1beta1"
unable to recognize ".../Downloads/scripts/kube-flannel.yml": no matches for kind "DaemonSet" in version "extensions/v1beta1"

Kubernetes’s version from

sudo ./install-prereqs.sh

is v1.16.3

Hello, I suggest you find a way to manually install v1.15.4. The v1.16.3 is not compactible with clara.

sysgen@sysgen-SYS-7039A-I:~$ helm ls
NAME                 	REVISION	UPDATED                 	STATUS  	CHART                	APP VERSION	NAMESPACE
clara                	1       	Tue Nov 19 16:59:58 2019	DEPLOYED	clara-0.2.0          	1.0        	default  
clara-dicom-adapter  	1       	Wed Nov 20 02:35:57 2019	DEPLOYED	dicom-adapter-0.2.0  	1.0        	default  
clara-results-service	1       	Tue Nov 19 17:00:01 2019	DEPLOYED	results-service-0.2.0	1.0        	default  
sysgen@sysgen-SYS-7039A-I:~$ kubectl version --short
Client Version: v1.15.4
Server Version: v1.15.6

Thanks egamor18 for the question!

We updated ./install-prereqs.sh to install a specific Kubernetes version (in Clara Deploy version>=0.4.0[R4]), and we would support v1.16.x in the next release.

And, you can download/install the latest version (0.4.1, 12/10/2019) from the following links:

https://ngc.nvidia.com/catalog/model-scripts/nvidia:clara_deploy_sdk/setup
https://docs.nvidia.com/clara/deploy/ClaraInstallation.html