Why cannot my tx2 boot?

I designed a carrier board which is to connect jetson tx2 module. The tx2 cannot boot on my board, but it can boot on NVIDIA carrier board. I mesured the power up sequence signals,they are all right. Why cannot it boot?

Hi, did you check the strapping pin setting, the chapter 12.7 of OEM DG? If the setting is wrong, the system could fail to power on.

Hi, Trumany.
Thank you very much.
I checked strap pins UART2_TXD and UART1_TXD, found they are low, however according to page 66 on “OEM PRODUCT DESIGN GUIDE”, They should be high. Would you tell me why is this? I measured the power up signals, and found they all right.



How can I send the picture in JPEG format to you ? I captured the power on signals picture and saved as JPEG faormat.


You can compare the pin status between your board attached and dev kit board attached. And so find out if any violation. If have, please check if it is caused by any component on the line.

Also you’d better to check the status of Recovery pin so as to avoid entering recovery mode.

I compared the strap pins status between my board and dev kit board, found dev kit board strap pins are right, but mine are wrong. I don’t know why, because the power on signals are same at the 2 kind of boards.

I think that the 1.8V power rail in the tx2 module may be wrong, otherwise the strap pins UART2_TXD and UART1_TXD should be high. but I can not control it, and the CARRIER_PWR_ON signal is right which means the
1.8V power rail in the tx2 module is right.


I found that the power up sequence is diffrent from the pitcure on page 11 of “OEM PRODUCT DESIGN GUIDE”.
Only POWER_BTN# signal is diffrent. Mine is same as dev kit board signal. is mine right?

The Recovery pin is 1.62V , it is right.

Hi, Trumany.
I have disconnected UART2_TXD、 UART7_TXD and UART1_TXD pins from ohter components,and found UART2_TXD and UART1_TXD is wrong。The power up signals POWER_BTN#, CARRIER_PWR_ON, CARRIER BOARD VDD_1V8, RESET_OUT# are all right,please see attachment. However the UART0_TXD signal has not any responding. Why the tx2 don’t boot? The


Not sure why this happen, the module has no problem since you can get right result with it on nv carrier board. So still please check the difference between your board and nv’s to find the root cause.

I have encountered the same problem as you. Is it solved?

We also encountered same issue( means PMIC working properly but cpu not booting), And we checked all straping pin,All pins is in right state, but cpu still cannot work, seems it is stuck in some process.

Fortunately, the issue was solved with help from people in a forum(WEIXIN == WECHAT group). Below is solution, check if it applicable to yours.

PLS CHECK JTAG_GP1 (A11), it should be in Low(0), standing for normal operation; it will be in boundry scan mode if it is High(1).

hope the information help you guys.

Thank you for your reply.

I really pulled the JTAG_GP1 pin high, and after remove the corresponding resistor, the TX2 can be turned on normally. Thank you for your answer and successfully solved this problem.

Can I add your WeChat?We can discuss TX2 related issues together.My WeChat is fbdwxh.