Why can't I configure IO

I was going to configure the 40pin SPI function, but when I ran sudo /opt/nvidia/jetson-io/jetson-io.py, I entered the configuration screen, but it immediately dropped out, so I couldn’t configure the pin function. When I run sudo /opt/nvidia/jetson-io/config-by-pin.py check the pin command. The following error is displayed:

File “/opt/nvidia/jetson-io/config-by-pin.py”, line 84, in
File “/opt/nvidia/jetson-io/config-by-pin.py”, line 43, in main
raise RuntimeError(“Platform not supported, no headers found!”)
RuntimeError: Platform not supported, no headers found!

The board model I use is:Jetson xavier nx.

This is a Jetson Xavier NX question. I have moved it to the proper forum so support can assist.

I migrated Jetson Xavier NX’s system to hard disk. Was that why I couldn’t configure IO and had some undiscovered problems?

There is no update from you for a period, assuming this is not an issue any more.
Hence we are closing this topic. If need further support, please open a new one.

Your NX module is SD card verson or eMMC version?
What have been done on your system?