Why don't non-lipo batteries work to power the TX2?


I am looking at options to power my TX2 in a mobile way. I have read both documents:

  • Jetson Module Battery and Charger Design Guide
  • Jetson TX1-TX2 Module Battery and Charger Design Guide
  • I note they recommend li+ batteries. Is there a technical reason for this? I ask because I tried to power the board from a 15V dry cell battery pack (10 x 1.5 volt AA’s) and separately from a cordless drill pack (14,4V and very capable in terms of current output).

    Testing with a meter, the dry cell pack shows no load 15.4V and the drill pack shows 16.4V no load, both well within the stipulated 5.5V -19.6V limits.

  • In both cases the red LED lights, but the board will not power on.
  • There is a predictable voltage dip when trying to power the board on in both cases of between 0.3 - 0.9 volts (tested with meter record function and oscilloscope). This is measured at the barrel jack.
  • It has been suggested to me by a well known online TX2 developer that the TX2 will not turn on in the presence of such a voltage dip, and that many users have tried using a capacitor to prevent it. He uses a lipo battery to power his TX2 projects.

    I have not had any success with a total of 5000 uF added capacitors in parallel across the battery terminals, and allowing the caps to charge before attempting to turn on (charge confirmed by measuring across cap terminals with meter).

    The board works fine with the power brick (I tested this just now) so there is no fault. I have ordered a 3S 11.1V lipo pack in the hope this will work. I see that there is zero drop from the mains power brick when powering on (measured using the record function on my meter as well as oscilloscope), so do li+ batteries just have zero power drop?

    Thank you

    Hi, the voltage drop depends on the load capability of battery. You can check the spec of li+ battery to get the info.

    Hi, thanks for replying.

    Can you specify what the load capability should be, or what the TX2 allowable voltage drop is? It is absent from the nvidia documentation I have seen. I note that it will work between 5v to 19v, but it seems this sudden voltage drop on power on is what is stopping it booting.

    I will be using a kinect at around 500 mA draw (though this will come from a separate battery) and likely with jetson_clocks.sh active. jetson-inference and ros will be running so I am guessing the gpu will be going pretty hard.

    I have some lipos on the way specced at 11.1V and 1000 mAh / 25C output (i.e. max 25 amps out at 11.1V). Will this be sufficient? I really need some help from nvidia here as there seems to be a lot of confusion on the web over it. Unfortunately your documentation only specifies voltage and cell count on lipos.

    Many thanks

    Please check the Uncontrolled Power -down Case in OEM DG, if there is ~20% drop on VDD_IN, it can cause the uncontrolled power down.

    Just in case anyone else runs into this, in the end I solved the problem by getting a buck converter to regulate the voltage and then used a lipo battery as power supply. This way the voltage stayed steady enough to allow the TX2 to turn on.