WiFi+BT module installed on M.2 not detected/working on Jetson Xavier NX

WiFi and Bluetooth is not working on my Jetson Xavier NX after I installed the M2-JODY-W377-00C module (M2-JODY-W3 card) on the M.2 E-key slot. I have 3 u.fl antennas hooked up to the module as well.

It is not seeing the card when I type in lspci or lsusb in the terminal. I am also not seeing anything on the the WiFi settings on the desktop.

I am guessing that all the necessary drivers are not installed. Please advice on where I can find the drivers to install this card and get WiFi and Bluetooth working correctly.

No, it is not about the driver. The detection logic in lspci and lsusb does not need you to install any driver. It is NV driver from the beginning.

For example, if I plug in a wifi card from Realtek but I don’t install realtek driver, lspci will still show the card but it may not be able to use.

The driver missing case for them could only be you are not using the nvidia linux kernel, which sounds unlikely happen for now.

Please share your dmesg first.

dmesg.txt (70.0 KB)

Thank you for taking a look.

Do you have other cards to try?

I tried the nRF52840 M.2 Module module as well. This is a Bluetooth module from Nordic. Doesn’t seem to work. I tried the same nrf52840 chip set as a USB dongle. Also didn’t work.

I also tried Alfa AWUS036AC WiFi USB dongle. It detects it when I type lsusb. Doesn’t work.

I just placed the order for 2 WiFi modules in the M.2 E Key form factor from Intel (Intel 8265 and Intel 9260. Should arrive today. I’ll try those as well and keep you posted.

From all the tests I have done so far, the M.2 modules doesn’t seem to be “detected” nor “working”

Is it on NV devkit? or a board from other vendors?

I am using the reComputer j202 carrier board. It says on their website that it 1:1 matches the size and functional design as the carrier board of Nvidia’s official Jetson Xavier NX Developer Kit.

Also, I tried the Intel 9260 module today. It works out of the box. Yet to try the Intel 8265.

I would like to try to figure out the issue with getting the nRF52840 M.2 and the M2-JODY-W377-00C modules to work.


It is most likely some gpios are needed to be enabled so that those cards will set status to enabled.
Please check with the card vendor if this is needed.

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.