Wifi Card VS USB Wifi dongle on Jetson Nano

I am trying to stream a video (3840x1080) on a Jetson Nano over the Jetson’s hotspot using gstreamer,
If use the Intel wifi card (link) everything works perfectly, the stream is very good, and almost no delay at all.

However when I use this USB wifi dongle (link), the stream is very corrupted, I can’t even tell what’s in the frame, it’s all corrupted pixels.
I am using the exact same gstreamer command below , nothing has changed.

gst-launch-1.0 -e v4l2src device=/dev/video1  ! 'video/x-raw, width=(int)3840, height=(int)1080, framerate=(fraction)30/1' ! nvvidconv ! nvv4l2h264enc bitrate=8000000 insert-sps-pps=true ! rtph264pay mtu=1400 ! udpsink host= port=5000 sync=false async=false

PC Client reciever

gst-launch-1.0 udpsrc port=5000 ! application/x-rtp,encoding-name=H264,payload=96 ! rtph264depay ! h264parse ! queue ! avdec_h264 ! xvimagesink sync=false async=false -e

Any ideas why this is happening and if it is fixable ?

Can you measure the iperf result from this usb wifi dongle to your pc side?

@WayneWWW iperf gives very inconsistent results, the bandwidth ranges from 6 all the way to 42 MBits/Sec , that’s on the same variables, testing few minutes apart, (running iperf -s on the jetson and iperf -c -t 150 on my PC.

Please maximum the system performance to see if issue still the same.

It is set to max perf and still the same