WiFi Dongle with TX2i

I am currently struggling to install a WiFi driver to run my WiFi dongle on the TX2i with JetPack 3.3.

I tried these commands with a few edits (listed below) and it all ran with no errors.

sudo apt install git dkms
git clone https://github.com/jeremyb31/rtl8812au-1.git
cd rtl8812au-1
sudo ./dkms-install.sh
sudo modprobe -v 88XXau

I edited the Makefile in rtl8812au-1 so that “SUBARCH=arm64” and I also ran,

cd /usr/src/linux-headers-4.4.38-tegra
sudo make modules_prepare

The 88XXau module is now listed when “lsmod” is run BUT the wifi dongle will still not work.

Any help will be much appreciated. Thank you.

There isn’t much I can help with here, but if before plugging in the dongle you monitor logs via “dmesg --follow”, then you should see new logging as you go through steps to use the dongle. Posting the log changes from those steps might help (I won’t be able to help much, but with the logs others probably can).

Assuming this is USB, while monitoring, plug in the dongle. Then, if lsmod does not show the module, go ahead of load the module. Whatever shows up you should post here.

Do note that many WiFi dongles also require firmware (this is in addition to the driver). Many times the firmware is portable across architectures, and if not open source, might require downloading and installing from the manufacturer’s website (or the chipset’s website).

It may also be useful if you show the output of “ifconfig” and “iwconfig” and “route” while the dongle is installed.

Thank you linuxdev for your reply.

Running “dmesg --follow”, inserting the dongle and then loading the module returns an output of this:

[ 3991.996891] usb 1-2: new high-speed USB device number 13 using xhci-tegra
[ 3992.150758] usb 1-2: feature bit otg_vbus_off set
[ 3992.155594] usb 1-2: New USB device found, idVendor=148f, idProduct=5370
[ 3992.162535] usb 1-2: New USB device strings: Mfr=1, Product=2, SerialNumber=3
[ 3992.169779] usb 1-2: Product: 802.11 n WLAN
[ 3992.174143] usb 1-2: Manufacturer: Ralink
[ 3992.178391] usb 1-2: SerialNumber: 1.0
[ 3992.183217] xhci-tegra 3530000.xhci: tegra_xhci_mbox_work mailbox command 6
[ 4033.313437] usbcore: registered new interface driver rtl88xxau

“sudo modprobe -v 88XXau” returns:

insmod /lib/modules/4.4.38/updates/dkms/88XXau.ko

“lsmod” returns:

Module                  Size  Used by
88XXau               2115930  0

“ifconfig” and “iwconfig” give nothing for wlan0 or r0.

In terms of firmware, I can’t find any firmware that is downloadable for the Ralink5370.

Thanks again for your support.

From this log you know the basics of searching for and loading the driver is working:

[ 4033.313437] usbcore: registered new interface driver rtl88xxau

If the correct user space software is present and configured, then the dongle should work. It wouldn’t be unusual for there to be a user space library or other dependency requirement once the driver loads. Since you have the driver loaded and USB functioning correctly, then I would say that what remains is to research required user space software.

Many desktop installations install a lot of software which the embedded systems do not install by default. Embedded typically means that not as much disk space is available, and that the end user has some specialized use for the system, and thus the embedded release may be missing packages the desktop systems will have by default. I can’t answer what is missing, but I can tell you that you’ve succeeded to the point where we know the dongle is capable of working. Whatever is missing will be no different for the Jetson versus for the desktop PC (whatever is missing won’t care about this being a Jetson) other than being installed/configured or not installed/configured.