Wifi modules all have same mac address?

Hi, I’ve got a couple of jetson devkits and for some reason all the wifi cards seem to have the same mac address. I’ve googled for it and it sounds like this mac address may be a testing address. I haven’t been able to change it with either ifconfig or macchanger.

The mac address they all share is “00:90:4c:11:22:33”. Here is output of ifconfig from one of our devkits.

wlan0     Link encap:Ethernet  HWaddr 00:90:4c:11:22:33  
          inet addr:  Bcast:  Mask:
          inet6 addr: fe80::290:4cff:fe11:2233/64 Scope:Link
          RX packets:558 errors:0 dropped:0 overruns:0 frame:0
          TX packets:94 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:153060 (153.0 KB)  TX bytes:17746 (17.7 KB)

Does anyone know what might be the issue? I don’t think it’s related to the issue in thread: https://devtalk.nvidia.com/default/topic/901180/jetson-tx1/my-jetson-tx1-is-not-able-to-connect-to-wifi/

as we are able to connect to wifi, but if more than one devkit is on they seem to be stomping on each other for an ip-address.

Admittedly, I’ve never actually used the wireless, but the JTX1 I have uses a different MAC than what you list above. If more than one device wants to use the same MAC, this would indeed be an issue. I think it may be possible to change this temporarily to test via serial console during u-boot environment setup (hit a key to pause in serial console right after it boots, run “help” to see what you can alter…MAC should be on the list).

Actually it seems that sometimes it boots with MAC address “00:90:4c:16:70:01”. Right now I have three devkits all booting with that mac address. I’m not sure why sometime it’s that and sometimes its “00:90:4c:11:22:33”. In any case, thanks for the U-boot suggestion, I’ll try that.

Can you try running the WiFi Config Check script from this page?
The script should patch units with MAC address detected to remain as the default.

Thanks, that seems to have worked. I tried it on three machines and they all have new MAC addresses after reboot.

I’m having this problem on TX1 SoC’s removed from the devkit board. On the devkit board, they all had different addresses, but running them on a small carrier card, they all end up with “00:90:4c:16:70:01”. I suppose the dev board is supplying a MAC address in some way that isn’t available once the SoC is pulled off?

What’s the right way to assign a MAC address in this case? u-boot or something else?

I don’t know what the correct way is…I have noticed it can be assigned in u-boot. If you look at the u-boot environment variables via serial console you’ll see the variable.

Thanks - hmm, u-boot documentation mentions variables ethaddr, eth1addr, eth2addr but none of these are defined on my TX1. They are supposed to correspond to eth0, eth1, eth2, so not sure if they would be picked up for wlan0.

I’ve resorted to reassigning the MAC address after boot with ifconfig / etc/network/interfaces.