WiFi Roaming

Hi
We are looking into Wi-Fi roaming feature, that is, when there are several access points to the same SSID, the network card won’t automatically disconnect and reconnect to the closest one
We have tried this on Jetson NX EVB.

I tried to find an answer in the application level, and found several things that didn’t work:
Any Idea ?

We have tried so far :
1.

I’ve tried to run the following command, to control the roaming sensitivity:

sudo iwconfig wlan0 sens -70

The output is:

Error for wireless request “Set Sensitivity” (8B08) :
SET failed on device wlan0 ; Operation not permitted.

According to iwconfig man page: “Modern designs seems to control those thresholds automatically”, so this is probably not the solution.

  1. I found that there are parameters for the network driver under: /sys/module/rtl8822ce/parameters . There I found a parameter called rtw_max_roaming_times with the default value 2. I couldn’t find any information online about it, but I managed to modify it to 10000 (by adding a new configuration file to modprobe), but that didn’t help.

  2. I’ve tried to let the default linux NetworkManager control the connection by setting managed=true in /etc/NetworkManager/NetworkManager.conf. option wifi-wext-only is not defined, so according to the NetworkManager man page: “nl80211’ supplicant driver and background scanning are used. This enables seamless connection and roaming in RSA token-enabled Wi-Fi networks”. This didn’t work.

  3. I’ve tried to configure automatic bgscan in wpa_supplicant using the command:

sudo wpa_cli -p /run/wpa_supplicant -i wlan0 set_network 0 bgscan '“simple:5:-70:120”'

(meaning: sample for a better access point every 120 seconds, or every 5 seconds if connection level is low). The command ran successfully (output was “OK”), but did not actually enable the roaming feature (NetworkManager is still enabled).

1 Like

We don’t have any wifi test case for NX. Maybe you can try to contact Realtek to confirm if this chip, firmware and driver support what you want.

Thanks. Do you have any contact person for that ?

Sorry, I don’t have this info. And generally we don’t share such info on forum.