Wifi wireless adapter 802.11n usb 2.0 setup

Hi, im new to Linux and im having trouble installing the drivers and setting up my adapter…

here is my output for lsusb:

Bus 002 Device 002: ID 0bda:0411 Realtek Semiconductor Corp. 
Bus 002 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
Bus 001 Device 005: ID 046d:c338 Logitech, Inc. 
Bus 001 Device 004: ID 1ea7:0064  
Bus 001 Device 003: ID 0bda:f179 Realtek Semiconductor Corp. 
Bus 001 Device 002: ID 0bda:5411 Realtek Semiconductor Corp. 
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub

Also i found a forum that has a command to run

wget -N -t 5 -T 10 https://github.com/UbuntuForums/wireless-info/raw/master/wireless-info && chmod +x wireless-info && ./wireless-info

from:

https://ubuntuforums.org/showthread.php?t=2378849

I will leave a link to that wireless-info file below

https://file.io/NODCa5

I tried following the steps on Post #7 but i get the following error:

eduardo@eduardo-desktop:~$ sudo apt-get install --reinstall linux-headers-$(uname -r) linux-headers-generic build-essential dkms git
Reading package lists... Done
Building dependency tree       
Reading state information... Done
E: Unable to locate package linux-headers-4.9.140-tegra
E: Couldn't find any package by glob 'linux-headers-4.9.140-tegra'
E: Couldn't find any package by regex 'linux-headers-4.9.140-tegra'

Can anyone indicate me the right steps to set the wireless adapter correctly and install the corresponding drivers please.

Hi,

I think you should firstly provide the info of your adapter. In the lsusb list, I cannot tell which one is your wireless adapter due to lacking of info.

  1. If your adapter is not listed in lsusb, it indicates even nv usb driver is not able to detect it.
  2. If lsusb has your adapter, then you should install the driver of your device. This is normally provided by the vendor.

Also, you don’t need to (and cannot) download the linux-headers of tegra through apt-get. The default rootfs installed by jetpack already has it under /usr/src.

I have the same USB 2.0 Wifi adapter as visible on your lsusb -> ID 0bda:f179 Realtek Semiconductor Corp.
Could you explain how have you installed this driver?

Hi,
I am also facing same issue. I tried installing following driver “https://github.com/kelebek333/rtl8188fu/tree/arm” but while building and installing ‘rtl8188fu’ driver it is giving error “make all KVER=4.9.140-tegra…(bad exit status: 2)”.

Hi niranjanlad,

Please help to open a new topic if it’s still an issue. Thanks

Hi,
Yes, I am still facing same issue.I can’t use wifi dongle.

With Warm Regards,
niranjan

The page you just shared says this driver is only compatible with below kernel version. However, tegra is using kernel-4.9. Please contact the vendor and see if they have driver that can work on k4.9.

For Kernel 4.15.x ~ 5.9.x (Linux Mint, Ubuntu or Debian Derivatives)