Will versions of gcc later than 5.4 work with DeepStream SDK 1.5 on the Jetson TX2

The version of gcc flashed on the Jetson TX2 is 5.4.
Will later versions of gcc like 7.x work with DeepStream
and the other flashed libraries?

I can’t answer, but gcc7 seems to be rejected by nvcc for CUDA compile in general. There are gcc “compatibility” (previous versions) versions available which might help, although I believe it only goes back one generation. Linaro publishes all versions.

Hi Frederikk,

I am afraid not.
Do you have some specific requirement which only work with gcc7.x?
I can raise this requirement to Deepstream team.

Thanks
wayne zhu

We are porting some code that uses C++17 and use libraries that require C++17