Window drag lag with GeForce GTX 750, cinnamon, gnome, unity

I am developer, but i develop application software. I don’t have any hardware knowledge, in that manner.

But if nvidia engineers, didn’t solve this for this long, it is impossible that problem is just like that fixable. :D

Yup. They develop on Intel laptops and can’t fathom any other use case other than working on an Intel laptop.

And that is somewhat understandable, since Intel is the only one, of all graphic chip manufacturers, who doesn’t give a crap for Linux.

You’d be wrong. Only nvidia gives performance and near feature parity with the other platforms. Intel can’t even be bothered with modern versions of OpenGL, and their Linux performance always lags what they provide on Windows.

Am i now? Isn’t Intel the only one developing open source drivers for their chips?

I didn’t compare performance on Windows and Linux. Let’s be real, that is impossible, as long Linux has status that it has now. But only Intel, provided working graphics on every desktop environment, that i tried and every distribution. Opening dash with active blur was a little slower, but hey it worked. Every distribution, every desktop environment.

With old radeon i also had troubles, that i have now with this GeForce.

Prove me wrong, and point me to bug of this kind, as is this reapainting issue, that is unsolved for this long, and it is manifested in Windows.

It is not that Intel provides working graphics on every desktop environment. It’s that the developers of those DEs don’t know anything beyond laptops, all of which are Intel (because AMD is basically out of the laptop market). So these developers make things work on their own systems and then call it a day, and some of them (i.e., gnome) generally don’t care if their stuff doesn’t work on other people’s systems.

How much of an issue is this, really? Do you ordinarily move your windows around that quickly? I’ve honestly never had this issue in Ubuntu over the years.

No but i have stuttering all the time, and tearing in videos. Movies are practically unwatcheable, because of tearing. General performance is very bad, it is very obvious.

Thats a Xorg Server issue…
Next gen display servers will fix these stuff.

Intel has wonderful drivers. I have no complaints against their developers because they go above their call of duty.

Gnome developers anymore are too narrow-minded to look past their limited use cases. If you’re not on Intel graphics with Intel HDA audio, your experience will suffer heavily with their desktop. Games, or the use of OpenGL for something other than drawing the desktop is given nary a thought.

Empirically, Nvidia has the performance advantage on Linux. As much as I’d like to fall back to integrated graphics to use Intel drivers, the performance drop makes that insufficient.

For what it is, the nvidia driver isn’t that bad. The developers do what they can with the freedom they have, but they’re legally encumbered. I’m sure they’re working on improving several things for the future, but we can also give some direction by posting topics like this one, which point out specific shortcomings they should fix.

I’ve had somewhere satisfying performance for some time, but now i have problems again with the instalment of second monitor.

It is very expressed, as in the video with gnome 3 i posted.

I installed second, same model 24" benq, so i now have one connected through dvi, and other through hdmi. For example i open a new nautilus window, and it lags in dragging for some 30 seconds and then gets back to normal. And it is the same, almost every time.

Is there something i could do to improve performanc with second monitor?

I somehow stumbled upon this: https://bugs.launchpad.net/ubuntu/+source/unity-greeter/+bug/1292467.

And it looks like i am suffering from that bug. I unplugged the hdmi monitor, until after login and looks like things are normal now. Also installing latest driver 355.11 didn’t help.

Ubuntu 15.10 with 355.11 driver, same issues from the video in the start of this theme.

Is there light at the end of this tunnel? :(

Ubuntu 15.10 with 355.11 driver, same issues from the video in the start of this theme.

Is there light at the end of this tunnel? :(

Try ForceFullCompositionPipeline, which sounds like it should be standard for everyone these days - e.g. it fixes Firefox’s tearing when scrolling.

E.g. in /usr/share/X11/xorg.conf.d/50-nvidia.conf

Section "Device"
    Identifier "Nvidia Card"
    VendorName "NVIDIA Corporation"
    Driver "nvidia"

    # Remove the startup logo
    Option "NoLogo" "true"

    # Force proper vsync - i.e. no flicker in Firefox
    Option "metamodes" "nvidia-auto-select +0+0 { ForceFullCompositionPipeline = On }"
EndSection

Section "Module"
    SubSection "extmod"
        # Don't initialize the DGA extension
        Option "omit xfree86-dga"
    EndSubSection
EndSection

Topic is about completely different issue. Not sure why you posted this here.

It’s not that different. It’s just another weird solution to another weird problem.

If I were you, I’d simply try it.

Yes it is very much different. Because when you add this option, affects 3d acceleration and problem from this thread becomes even worse.

exact same problem here on gnome 3.18 with a gtx760. i can atleast fix the delayed window moving by setting “export CLUTTER_VBLANK=none”, but this gives me tearing, so it is overall not a big win.

setting “Option “metamodes” “nvidia-auto-select +0+0 { ForceFullCompositionPipeline = On }”” fix atleast tearing without delays, but it also affects opengl performance, which makes it really useless for me.

it is btw. hard to record a video about this behavior, because even with disabled vsync its looks delayed in the video.

Did i understand you right? You’ve set both CLUTTER_VBLANK=none, and Option “metamodes” “nvidia-auto-select +0+0 { ForceFullCompositionPipeline = On }” right?

Did that fix the dragging problem without tearing?

exactly.