Windows 10: Cannot launch Julia under nsys; Agent daemon did not report success until timeout

I have an windows 10 with a NVIDIA GeForce GTX 1050 Ti with drivers 516.94.0 and CUDA 11.8 with drivers 11.7.

I’ve installed Nsight Systems 2023.2.1to profile a Julia code that is using the CUDA.jl package, but when I try to launch Julia under nsys I get the following error:


I actually managed to run it one time before, right after installing the Nsight Systems, but after that it didn’t run anymore. I already tried rebooting the system a couple of times, but it didn’t seem to make a difference.

Thanks in advance for a response,

We have a known issue with OS runtime trace and Julia. Could you try the below to skip OSRT?

nsys profile --trace=cuda,nvtx -d 20 julia

@afroger for followup.

Thank you for the answer, skipping runtime did work

I have an windows 10 with a NVIDIA GeForce GTX 1070 with drivers 531.61 and CUDA 12.1.

I have the same issue and tried this answer, but it still doesn’t work:

PS C:\WINDOWS\system32> where.exe julia
PS C:\WINDOWS\system32> nsys launch julia
Program not found: julia
PS C:\WINDOWS\system32> nsys profile --trace=cuda,nvtx -d 20 julia
Program not found: julia

The weird thing is I can find find the julia path but nsys can’t find it. Do you have any idea how to fix it?

Thank you in advance,

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.