WIndows 10 CUDA installation failure solved

Can I please know where is “visual studio integration” located? and how to disable it?

2 Likes

Update : I am unable to uncheck it , if I uncheck visual studio integration ,even the cuda gets unchecked

Any one who is facing this problem, I was also facing the same problem. I had done everything above but still it did not help me. Then I did the following:

  1. searched for storage settings (in next to windows icon)
  2. clicked on apps and features option
  3. scrolled down and uninstalled every options that had nvidia written. (Restart is required after uninstalling)
  4. Again installed the cuda with recommended option instead of custom. (success) :)

It’s worked , thanks for the advice

Thanks aton. This helped alot. Finally solved it after a whole day of effort. Unchecking Visual Studio Integration is also required.

Unchecking everything mentioned in this post still helps my PyTorch run of Cuda.


why…?

Try disabling Visual Studio Implementation in the Custom Install under the CUDA option. It solved it for me. :)

I had a problem installing CUDA 11 with similar symptoms. (Also, nvidia-smi showed Cuda v10, and deviceQuery failed.) I needed to update Windows 10, update VisualStudio to 2019 then repeatedly uninstall all Nvidia programs. An older DLL NVCUDA64.dll (from an earlier CUDA v10 install) was particularly stubborn, but finally was able to remove it, reboot, then installing CUDA v11 worked ok.

Hello GuyMadison Sir!

I have excluded Drivers in CUDA Custom install, but how to exclude the GeForce Experience?
If you could guide me properly, it would be so kind of you.
Thank you.

Regards
Khan

I have tried to install cuda 9.0 it failed many time.
In my case it has been solved by selecting installation option custom and unchecked the visual studio integration under the CUDA option .

Thanks for the work around. Wouldn’t it make sense to fix the installer so it doesn’t fail if the GeForce Experience is already installed? It’s been an issue since 2018.

Wouldn’t it be nice to even know WHY the install fails instead of just listing all the things that failed to install…

1 Like

I am using uni desktop so I can’t disinstall Geforce experience. And downloading CUDA keeps failing.

Can you explain step by step how to do a custom install please?

I can’t see the custom installation

That worked in my case as well. Finally!!!

@GuyMadison I just singed up to say thank you…
So, thank you…

go to custom installation instead of express intallation there you can find the tree like structure and you can see the visual studio integration part

Is there a way to install cuda along with GeForce Experience and Graphics Drivers? I already have GeForce installed for gaming. Now I want to do some machine learning along with gaming. for that I need to install cuda toolkit.

I have installed Cuda 10.1, 10.2, 11.1, 11.2, and 11.4, with Geforce Experience installed. Never had an inkling of an issue wrt cuda (I did once have an issue with geforce driver update). Now, however, I cannot get past “checking system suitability” to install Cuda 11.5. I have Win 10 21H1. I like having Geforce experience for VR. I use Cuda for computation. It would be nice if they worked well with one another. It is the same company for pete’s sake.

how did you disable and from where?