Windows 11 (wmic.exe is removed)

hello, I have the exact same error as described above. Also using Windows 11:
Microsoft Windows 11 Home Insider Preview
Version 10.0.22494 Build 22494

Hello I have the same problem on windows 11 Pro Insider Build 22494. Tried to copy the WMIC.exe from windows 10 available online (EXE Files - Your Source for File Downloads Since 1999> not sure if link has virus (do not blindly follow.) to my C:\Windows\System32\wbem\ folder but this does Not work.

I’ve got the same error here

Same error here as well.

Same error here…
Running Windows 10 not 11!

I have same error.

Need some work around…

I also have this problem as below. I am using Windows 11 Pro version.

“Failed to initialize the user session: Error: Command failed: cmd.exe /c wmic path win32_VideoController get name ‘wmic’ is not recognized as an internal or external command, operable program or batch file.”

Just for info:
The WMIC tool is deprecated in Windows 10, version 21H1 and the 21H1 semi-annual channel release of Windows Server. This tool is superseded by Windows PowerShell for WMI. Note: This deprecation only applies to the command-line management tool. WMI itself is not affected.


They also removed it from Windows 11 Dev builds.

Do you have some work around??

I cannot use omniverse tools at all for a week.
This is kind of fatal.

I searched some work around and run below , partially work.



but did not work full function…

1 Like

Any update on this? Is there a patch available or work around?

Hey All! Sorry for the late reply. I’ve been chatting with the development team about this issue. Here is the latest information that I have.

As mentioned above, the error is happening because the wmic utility tool is not included with Windows 11. This breaks our startup code from collecting the hardware information.

It sounds like our launcher does not currently support Windows 11. I have escalated this issue and I will post an update here. Thank you so much for your patience!


New information that may help:

The WMI command-line (WMIC) utility is deprecated as of Windows 10, version 21H1, and as of the 21H1 semi-annual channel release of Windows Server.

Latest Windows 11 Pro release 21H1 OS Build 22000.318 still has it.

1 Like

Our development team is working on a solution, but we have a workaround for now.

If you are running an English version of Windows 11, copy the c:\windows\system32\wbem\wmic.exe and c:\windows\system32\wbem\en-US\wmic.exe.mui from Windows 11 22000 to your current OS under the same location.

1 Like

Sadly the workaround is not working for me. :(
WMIC is working, but now I get another error:
Failed to initialize the user session: Error: Command failed: cmd.exe /c wmic path win32_VideoController get name Invalid XSL format (or) file name.
Running Windows 11 Pro Insider Preview.

For the ones who want to try it:
I’ve extracted the files from the Windows 11 Pro build 22000.318 iso

Hi ! The workaround is also not working for me and get below error !!

“Failed to initialize the user session: Error: Command failed: cmd.exe /c wmic path win32_VideoController get name Invalid XSL format (or) file name.”

Running Windows 11 Pro Insider Preview.

It is better to wait for the solution from development team.

1 Like

when i clicked Restart Launcher for update, launcher didnt work now, before of clicking all working fine.
Omniverse Create works from .bat file in ov\lib\create-2021.1.1\omni.create.bat

Windows 11 Insider Preview 22509.1000 (rs_prerelease)

1 Like

Any news for when this is gonna be fix?

Tried the workaround and it does not work for me as well

1 Like

Hi Everyone! The development team has informed me that this will be fixed with the next launcher version release. I do not have an ETA as of yet.

1 Like

That would be a great Christmas gift… [wishful thingy]

Edit: Woohoo!! I’m on Windows 11 Pro Insider Preview and the workaround works after installing the latest update (build 22518).
So, if you’re running Windows 11 Pro Insider Preview, update windows to the latest build, download the zip in my previous post, extract the content to C:\Windows\System32\wbem\ and you’re good to go.

1 Like

Yes, I succeeded too by following gebruiker244’s idea as above !!