Windows install of any apps stopping near 90%

So I had this installed at the office on Linux without issues but installing on Windows is giving me issues.

What’s I’ve done so far:

  • download the omniverse installer and install (no issues)
  • reboot

from this point on whatever I need to install (for instance, the cache, nucleus server or any apps) seems to pause towards the end stage of the install. If i kill the app and relaunch it usually fixes the issue and continues but some of the larger apps just restart the full download and get back to the same stage.

I’ve tried launching as administrator but seems to make no difference. I’ve launched from terminal to get some feedback and you can see some errors in the screenshot attached. Any ideas whats causing this?

System spec:

windows 11
amd ryzen 7 3700x
rtx2070 12gb (driver v536.99)
32gb ram

@danwnewlands can you upload the OV Launcher log file? you can find it here - C:\Users\%username%\.nvidia-omniverse\logs\launcher.log

and on a separate note - per technical requirement and minimum spec listed under the Composer/Create app, you might need an upgrade to minimize bottleneck. some apps won’t launch properly if the hardware specs aren’t met.

Thanks for the quick reply there! Log attached!

This system isn’t ideal but I did have this all running about a year ago on the same build, maybe the requirements have changed since, which is understandable.

launcher.log (84.9 KB)

it appears you have tried installing Presenter as well, and is it safe to assume you were experiencing the same issue as well? can you confirm you have established a localhost Nucleus server already?

based on the log, the error that seem to be attributing the problem could be the following

[2023-08-20 21:42:28.344] [error] (node:928) Warning: Closing file descriptor 5 on garbage collection
[2023-08-20 21:42:28.344] [error] (node:928) [DEP0137] DeprecationWarning: Closing a FileHandle object on garbage collection is deprecated. Please close FileHandle objects explicitly using FileHandle.prototype.close(). In the future, an error will be thrown if a file descriptor is closed during garbage collection.
[2023-08-21 09:34:11.386] [error] (node:3756) Warning: Closing file descriptor 5 on garbage collection
(Use `NVIDIA Omniverse Launcher --trace-warnings ...` to show where the warning was created)
[2023-08-21 09:34:11.386] [error] (node:3756) [DEP0137] DeprecationWarning: Closing a FileHandle object on garbage collection is deprecated. Please close FileHandle objects explicitly using FileHandle.prototype.close(). In the future, an error will be thrown if a file descriptor is closed during garbage collection.

and don’t worry, i don’t expect you to understand what those lines of code mean (honestly, i don’t either). but just wanted to highlight those errors for the devs once they are able to look at this thread.

Looks to me like its working as expected. Its installed but still says Add server but seems like thats only if working in collaboration? It still would work locally right?

the OV System Monitor, the page that you have pulled up, is showing all services are running, which is good to see. what interests me, though, is whether there’s a localhost Nucleus server. even if you choose not to collaborate with other users, i’d still strongly recommend you set one up locally (given if you’ve not done so already).

you can navigate to the Nucleus section of the OV Launcher and “Connect to a Server”. you will be prompted authentication with a server name; at this point, you can enter “localhost” followed by the user and password that you’ve set up during Launcher install. If you do not remember your credentials, you should be able to use “admin”:“admin” for both. afterwards, try reinstalling the apps and see if it helps.

as another user, i have not seen the log report on garbage collection, so i am just going through process of elimination at this point. but if we have to, we may need to run the Cleanup Tool to reset the Launcher. however, i’d like to reserve that as last resort.

So I did indeed miss that, apologies! After setting that up, killing and relaunching the app it still behaving the same though.

I am still in setup stage so happy to perform a clean if needed

Just to add, I just run that cleanup tool and started fresh, installing the cache (still same hanging issue) then installing the server (same hanging issue) then making the localhost and now running a download of the composer app to see if i can get through the hanging.

can you upload the Launcher log again now that you’ve ran through the Cleanup Tool? i’d like to confirm if the same garbage collection issue is persistent or it’s something else new. (to confirm, you’ve been launching the Launcher via admin privilege, correct?)

do you happen to have any antivirus/firewall set up?

Sure thing! I’m the only user with full admin rights on the machine anyway but I’m just trying to launch the app with admin just to be sure, it made no difference before though.

No antivirus or firewall other than the windows firewall but i cant see any issues there.

launcher.log (58.5 KB)

unfortunately, it appears the same issue persists in the new log.

when the progress got stuck during Cache and Nucleus server installation (after you ran the Cleanup Tool), did you force quit the Launcher and reinstalled like you had described in your first post?

also, when Composer got stuck, can you confirm if it’s consistently during Kit-Kernel download?

Yea each time it gets stuck nothing happens (left it for an hour once) till I close the app then exit the application from the system tray. The reopen the app and it continues.

Not always on the kernel but it does seem commonly to be there. Could just be the timing of the gui updates though? This is the latest test from me now after all the above.

have you ever tried to reinstall Launcher at all (purely inquiring and not requesting you to do so)? or, by stating “download the omniverse installer and install (no issue)” as a step you’ve done, you meant you’ve tried to reinstall already?

Yea I’ve reinstalled it fully before, cleaning it off my system, never seemed to change anything. I’ll try dropping gpu driver version down to whats mentioned as recommended but I’d assume that wouldnt effect the install phase?

Appreciate the help too*

the error might be more code based than anything else. based on both logs you’ve provided in this thread, the kit-kernel encountered an issue between saving and extraction to location C:\Users\danwn\AppData\Local\ov\pkg\deps\b7a0b9df5a1918450373458b74d781d8, causing the process to be hung up and not be able to link to associated apps (in this case, Composer).

even though we’ve tried a few things, they aren’t strictly geared towards debugging this specific problem; still, thanks for trying a few things out. i am hoping some of the logs and reports found can provide the dev with a bit more context.

1 Like

Do devs typically check these forums? Should I just wait?

Thanks for all your help man!

yea, i would give them at least a few hours if you can wait.

Yea no worries at all!

Just to update after doing the above I restarted and then suddenly I was getting prompts by the firewall to allow. I still needed to restart the app once allowing but the install went through and everything seems to be working fine.

So still seems to be some bug there but I assume the localhost server not running and also the firewall not being prompted was the thing. Maybe disabling the firewall during installation would have stopped the issue.

Thanks for your help today, really appreciate it

1 Like

glad to hear you got it working! and thanks for reporting back the solution you found 👍