WINE and Nvidia: display state seems one step/frame behind

I’m experiencing quite annoying issue when using Nvidia proprietary driver under Linux - in quite a bit of apps I launch through WINE the things that are displayed on screen seem to be one state/frame behind what they actually are.
So for example when I mouse over something and the object should highlight - it does not. It actually does when do any other action afterwards - rotate or move the pointer out of the object space. Other example - when I try to select things and the selection border is drawn it should disapper as soon as I release mouse button. Sadly it doesn’t.
But better to show it rather that trying to explain it:

In this example you could see this behaviour with MoI3D under WINE.
I’ve tried multiple WINE versions and multiple distros (video recorded on OpenSUSE Leap 15).

This happens ONLY with Nvidia’s proprietary driver. Intel and AMD work as expected (Nvidia with Nouveau too).
I’ve tested this on 4 diffferent PCs in my workshop - results are the same. One interesting addtional observation I made is that I got this bug to show up on AMD RX 560 as well when it has been inserted after I’ve tried Nvidia first and installed Nvidia’s proprietary drivers before putting in RX 560. Not sure it was something Nvidia driver install in the settings caused or whether it was Nvidia GPU present in another slot (and thus module for ot loaded)- it was a tricky setup where I have multiple GPUs. I’ll do further testing to determine whether driver install is enough to trigger the problem or whether you need to have Nvidia card plugged.

Anyways would love to hear your thoughts on the matter - any ideas for workarounds?