Hi, im trying to install wine on the jetson-tk1, i already added the repository ppa:ubuntu-wine/ppa
then i tryied sudo apt-get update and then sudo apt-get install wine1.7

and i got

[sudo] password for ubuntu:
Reading package lists… Done
Building dependency tree
Reading state information… Done
E: Unable to locate package wine1.7
E: Couldn’t find any package by regex ‘wine1.7’

also software center says

There isn’t a software package called “wine1.7” in your current software sources.

I’m not sure but I think Wine has no purpose on an ARM CPU so dont bother installing it.
Windows is only for x86, if you want Windows on Jetson TK1, install QEMU and there you can install Windows.

I see, thank you didnt know that, so does that mean that there might be no way of installing windows games on the jetson-tk1?

QEMU and Wine is known to work rather well.
QEMU emulates a x86 CPU which then launches WINE. Of course the extra-wrapper causes some performance drop but the Jetson TK1 should be powerful enough still.
DOSBOX, however, runs quite well out of the box.

It would be best if Android was available for Jetson TK1, then we would have tons of games.
However, I recommend you some cool Linux ARM compatible games such as Minetest, Xonotic (ask if you need help installing, its the best looking game I could get working on this device), Nexuiz, Sauerbraten… Search the Software Center

Android would be the best for Jetson though

I have build wine in ubuntu of ARM chromebook, and wine supports arm now. but most programs was writen for x86, the arm wine won’t run it.
I think,the arm wine could run winRT/winCE apps,it’s another way to expand ARM-ubuntu.

well the I tried to install wine with the apt-get after i had added i386 architecture and it said that i had held broken packeges, I looked up the solution for ubuntu, and it said i had to remove the architecture and try again but to remove the architecture i had to remove all i386 apts so i did this took away network management, witch i was only able to fix by putting the jetson into recovery mode and flashing it, it worked and the jetson is working again, but i dont understand if its not suposed to have i386 packeges why was the network management uninstalled with those packages.

i386 is x86 32 bit. jetson is armhf.
What do you need to run on Wine?

Don’t add i386, Jetson is ARMv7. However, you can add two architectures at once, e.g., on my fedora development machine, I often have 32 bit compatibility in addition to 64 bit versions of libraries. 64 bit x86 can often handle compatibility 32 bit versions which are also x86…but ARMv7 will never handle i386.

I can’t say for sure, but it is quite possible your i386 network management software and ARMv7 had files in common on both architecures…such as configuration files which are not binary files…and that it removed only i386…but that meant config files as well.

Well, i just wanted to see if i could run HaloCE on the jetson so i needed thought wine, could there be another way of installing it? in anycase thanks

Hey, I’m having the same problem with wine and the TK1. Is there another program like wine that is usable?

I dont think so. You cant run x86 apps on arm anyway. Just wait for Exagear emulator.