Wireless access point SSID keeps disappearing

As many others on this forum, I’m trying to run the Jetson TX2 as an access point at boot. I chose to deinstall hostapd, disable dnsmasq, and try to get this working exclusively with NetworkManager and wpa_supplicant.

My problem is that the access point only appears every now and then, and eventually disappears more often than not. When it is visible, I can connect to it and everything works as its should. When it is not to be seen, I cannot force the connection as the network is not found.

Specifically, I run

nmcli dev wifi hotspot ifname wlan0 ssid wirelessap_35a0 password 1234567890 con-name Hotspot

to start the access point. When running

nmcli d wifi

I can see the connection correctly being displayed

  • SSID MODE CHAN RATE SIGNAL BARS SECURITY
  • wirelessap_35a0 Infra 1 0 Mbit/s 0 ____ WPA2

Similarly, wpa_cli shows

sudo wpa_cli
wpa_cli v2.4
Copyright (c) 2004-2015, Jouni Malinen <j@w1.fi> and contributors

This software may be distributed under the terms of the BSD license.
See README for more details.


Selected interface 'wlan0'

Interactive mode

> status
bssid=00:04:4b:a5:35:9e
freq=2412
ssid=wirelessap_35a0
id=0
mode=AP
pairwise_cipher=CCMP
group_cipher=CCMP
key_mgmt=WPA2-PSK
wpa_state=COMPLETED
ip_address=10.42.0.1
address=00:04:4b:a5:35:9e
uuid=2e521a06-6bce-5b3a-9c39-daa14f2d5af0
>

Inspecting the status of wpa_supplicant is a little more ambiguous

systemctl status wpa_supplicant
● wpa_supplicant.service - WPA supplicant
   Loaded: loaded (/etc/systemd/system/wpa_supplicant.service; disabled; vendor preset: enabled)
   Active: active (running) since Tue 2018-11-13 12:24:49 UTC; 4h 25min ago
 Main PID: 1094 (wpa_supplicant)
      CPU: 2.175s
   CGroup: /system.slice/wpa_supplicant.service
           └─1094 /sbin/wpa_supplicant -u -s -O /run/wpa_supplicant

Nov 13 16:41:59 smarthand wpa_supplicant[1094]: nl80211: Failed to create a P2P Device interface p2p-dev-wlan0
Nov 13 16:41:59 smarthand wpa_supplicant[1094]: P2P: Failed to enable P2P Device interface
Nov 13 16:41:59 smarthand wpa_supplicant[1094]: wlan0: CTRL-EVENT-SCAN-FAILED ret=-22 retry=1
Nov 13 16:42:00 smarthand wpa_supplicant[1094]: wlan0: CTRL-EVENT-SCAN-FAILED ret=-22 retry=1
Nov 13 16:42:24 smarthand wpa_supplicant[1094]: wlan0: CTRL-EVENT-SCAN-FAILED ret=-22 retry=1
Nov 13 16:42:50 smarthand wpa_supplicant[1094]: Using interface wlan0 with hwaddr 00:04:4b:a5:35:9e and ssid "wirelessap_35a0"
Nov 13 16:42:50 smarthand wpa_supplicant[1094]: Device is trying to offload WPS Probe Response while not supporting this
Nov 13 16:42:50 smarthand wpa_supplicant[1094]: wlan0: interface state UNINITIALIZED->ENABLED
Nov 13 16:42:50 smarthand wpa_supplicant[1094]: wlan0: AP-ENABLED
Nov 13 16:42:50 smarthand wpa_supplicant[1094]: wlan0: CTRL-EVENT-CONNECTED - Connection to 00:04:4b:a5:35:9e completed [id=0 id_str=]

Other things I’ve tried are

set beacon_int 110

using wpa_cli as the default value of 0 does not make sense to me, as well as

sudo nmcli conn mod Hotspot 802-11-wireless.hidden false

I get the same problem when using the instructions based on hostapd as described in the other threads, which introduces many other potential pitfalls as DHCP has to be configured manually and I do not want to disable network manager. Help would be greatly appreciated!

Regards,
Nikolaus

nikolaus0r056,

This issue is similar to others. However, we didn’t get final response from other forum users.
I would like to know that if you could try the way our QA test the AP.
That is, please use the NetworkManager GUI on ubutnu desktop to setup the AP. If it works, please check if it would disappear. Please also try scenarios with WPA2 enabled/disabled.

If this could work, then we move into your case step by step. For example, use nm_cli command to enable wifi AP. Try with smartphone or other device to check the connectivity first and then move to wpa_supplicant…

Hi Wayne,

Thanks. As you suggested, I have also used

nm-connection-editor

to setup a wireless access point using the Ubuntu GUI without security (“open”). The behavior is the same, the access point eventually appears, but is not visible on all my devices, e.g. only on my Mac, but not iPhone, and eventually disappears a few minutes later. As I described earlier, this behavior is not visible from the Jetson, with all relevant tools reporting normal operation.

I note that NetworkManager still uses wpa_supplicant internally to manage this connection, even if no encryption is used. As before, I can see the creation of the AP as well as a connection (and deliberate disconnection) attempt by invoking systemctl status wpa_supplicant

Nov 14 08:26:19 smarthand wpa_supplicant[1094]: wlan0: AP-ENABLED
Nov 14 08:26:19 smarthand wpa_supplicant[1094]: wlan0: CTRL-EVENT-CONNECTED - Connection to 00:04:4b:a5:35
Nov 14 08:38:29 smarthand wpa_supplicant[1094]: wlan0: AP-STA-CONNECTED 98:5a:eb:8d:ee:86
Nov 14 08:38:54 smarthand wpa_supplicant[1094]: wlan0: AP-STA-DISCONNECTED 98:5a:eb:8d:ee:86

As I can remain connected to the access point and use it for hours once it was briefly visible, I believe the problem has exclusively to do with the way the SSID is broadcasted.

It sounds an issue. Could you share which Jetpack is your device using?

If your have any device connected to AP, would it lose connection as well?

We are using

R28 (release), REVISION: 2.1, GCID: 11272647, BOARD: t186ref, EABI: aarch64, DATE: Thu May 17 07:29:06 UTC 2018

once I connect, the connection is stable, it really just has to do how the SSID is advertised. In particular, I can (sometimes) join the network even when it is invisible, albeit only when its “open”. Using WPA/PSK, the invisible network cannot be found. We use wire antennas and RSSI is around -84 dBM, 2-3 bars, not great, but should not be the issue.

I also provide a dump of the wireless device options that are specific to the current driver.

sudo wpa_cli
[sudo] password for nvidia: 
wpa_cli v2.4
Copyright (c) 2004-2015, Jouni Malinen <j@w1.fi> and contributors

This software may be distributed under the terms of the BSD license.
See README for more details.


Selected interface 'wlan0'

Interactive mode

> dump
ctrl_interface=/run/wpa_supplicant
ctrl_interface_group=null
eapol_version=1
ap_scan=2
disable_scan_offload=0
fast_reauth=1
opensc_engine_path=null
pkcs11_engine_path=null
pkcs11_module_path=null
openssl_ciphers=null
pcsc_reader=null
pcsc_pin=null
external_sim=0
driver_param=null
dot11RSNAConfigPMKLifetime=0
dot11RSNAConfigPMKReauthThreshold=0
dot11RSNAConfigSATimeout=0
update_config=0
device_name=null
manufacturer=null
model_name=null
model_number=null
serial_number=null
config_methods=null
wps_cred_processing=0
p2p_listen_reg_class=0
p2p_listen_channel=0
p2p_oper_reg_class=0
p2p_oper_channel=0
p2p_go_intent=7
p2p_ssid_postfix=null
persistent_reconnect=0
p2p_intra_bss=1
p2p_group_idle=0
p2p_passphrase_len=0
p2p_add_cli_chan=0
p2p_optimize_listen_chan=0
p2p_go_ht40=0
p2p_go_vht=0
p2p_disabled=1
p2p_go_ctwindow=0
p2p_no_group_iface=0
p2p_ignore_shared_freq=0
bss_max_count=200
bss_expiration_age=250
bss_expiration_scan_count=2
filter_ssids=0
filter_rssi=0
max_num_sta=128
disassoc_low_ack=0
interworking=0
access_network_type=15
pbc_in_m1=0
autoscan=null
wps_nfc_dev_pw_id=0
ext_password_backend=null
p2p_go_max_inactivity=300
auto_interworking=0
okc=0
pmf=0
dtim_period=0
beacon_int=0
ignore_old_scan_res=0
scan_cur_freq=0
sched_scan_interval=0
tdls_external_control=0
osu_dir=null
wowlan_triggers=null
p2p_search_delay=500
mac_addr=0
rand_addr_lifetime=60
preassoc_mac_addr=0
key_mgmt_offload=1
passive_scan=0
reassoc_same_bss_optim=0

Are you using custom carrier board or devkit? It would be better if this issue can be reproduced on devkit.

We are using the J90 carrier board from Auvidea. Does the wireless access point functionality works reliably on your devkit?

It turns out that the wireless issues were lack of signal strength that made the behavior unpredictable/spotty. Using a better antenna solved this issue. I can confirm that the access point feature works using the Auvidea J90 extension board using NetworkManager and wpa_supplicant.

It turns out that information I found here on the forum

[i]To enable SSID broadcast, the driver’s op_mode parameter has to be set to 2.

This can be set in two ways:
Manually via /sys/module/bcmdhd/paramters/op_mode node.
Add the following line to /etc/modprobe.d/bcmdhd.conf:
options bcmdhd op_mode=2
[/i]

is critical. Only if the mode is set to “2”, the access point shows (no error message in the system), but connecting to other access points does not. You will need to set the mode to “0” if you want to run the wireless network in managed mode, and I haven’t found a way to switch modes using the standard tool.

I am using J120 carrier board with Jetson Tx2. Could you please explain how you are using better antenna since everything is integrated? I do not see any separate antenna as it seem to be integrated.

The antennas need to be connected to the TX2 itself, there are two U.FL mini RF connectors at the short-end of the TX2. They are a little hard to reach. See for example here