wireless connection issues on TX2

I am trying to get rssi on Jetson TX2. I used the function ioctl, but it just threw out error “Invalid argument”. I also tried to use other requests in the linux/wireless package, but all threw out the same error. It can connect to a wifi network normally, but when I ran iwconfig, every item showed “no wireless extensions”.
ifconfig returns eth0, l4tbr0, lo, usb0, usb1 and wlan0 normally.
rfkill list

0: bluedroid_pm: Bluetooth
	Soft blocked: yes
	Hard blocked: no
1: phy0: Wireless LAN
	Soft blocked: no
	Hard blocked: no
2: brcmfmac-wifi: Wireless LAN
	Soft blocked: no
	Hard blocked: no

I am not sure what other commands may help solving the problem. I have tried rebooting, but that made no sense.
Thank you for any ideas/assistance.

could you extend what is rssi, please?

rssi means Received Signal Strength Indication. I just used SIOCGIWSTATS to get the signal strength but failed.

How about nmcli command? Though I think the “signal” may be the percentage.

For example, “sudo nmcli dev wifi list”

Thank you.

I tried nmcli command,and it can successfully output signal strength in percentage, but how can I get that in my program?

Another question, when I use p2p connection between two TX2s by p2p-wlan0-0, nmcli command also doesn’t work, are there any other solutions?