Wireless debugging

Hi,

I was able to debug through a wireless connection using Eclipse.

Wireless debugging with VS fails with the following error:

Failed to attach: The given path's format is not supported..

Some details:

Using VS:
I was able to deploy and run using VS but debugging or attaching fails with the above error.

Using Eclipse:
Wireless debugging was possible using both the native ADB debugger and the ARM DS-5 debugger.

I’m using an app called adbWireless for ADB over WiFi
(https://play.google.com/store/apps/details?id=siir.es.adbWireless)

Hi EtiH_x,
which version of the Nsight Tegra do you use?

The latest, 2.0r2.

Hi EliH_x,
I sorry about it. This is a issue on Nsight Tegra, we will fix it in the future release.

Has this been fixed yet? I’m using version 1.4 of the Tegra NSight plug in, and it doesn’t seem to be.

I’m trying to debug on the Mad Catz M.O.J.O., which has a Tegra 4, but only supports debugging over ethernet, so this is pretty important to have working.

Thanks!

-Matt

Hi Matt,

Nope - unfortunately, it’s still not supported in the latest Nsight Tegra (v1.5). However, this feature seems to be popular among other users and it should be released rather sooner than later.

+1 for really wanting this fix.

I’m getting the same issue with TADP 2.0r8 and trying to debug wireless to OUYA. It will work if I select Start without debugging, but not if I try to debug.

Any updates on when this fix is due?

Hi Derek,

The fix will be a part of the next Nsight Tegra release.

Great. Thanks.

Any news regarding this issue?

Having bought a M.O.J.O for tegra development, there is currently no way to deploy and/or debug
apps using the Tegra Visual Studio plugin, which is highly disappointing.

The plugin seems to be running its own version of adb. Having the possibility to fire adb commands
for the plugin’s adb instance would be sufficient, I guess.

Hi FelixK15,

Nsight Tegra have been supporting wireless debugging for a long time already. Can you explain how did you set it up on your machine and what went wrong/didn’t match your expectations? Nsight Tegra also doesn’t use an ADB instance directly, running a new ADB process for each new command instead. We use adb.exe from the Android SDK specified in options.

Hi Dmitry,

thanks for your quick response :)

Basically I just installed the latest TADP package and enabled the developer mode on my M.O.J.O.

Issuing adb commands using adb.exe AFTER connecting to the M.O.J.O. via "adb connect " works fine and the device is successfully listed when calling “adb devices”, however whenever I start up Visual Studio, the device is not listed in the Tegra->Device->Select menu.

My suggestion would be that the plugin can’t find the device as I have to manually establish the connection via “adb connect” first?

Edit:

I also tried to manually connect to the M.O.J.O via the commandline while Visual Studio is running but that just ends up in a “killing adb server - adb server out of date” loop.

The “adb server out of date” message could mean that there are several incompatible versions of adb on your PC. While Nsight Tegra uses the one from TADP’s Android SDK, there might be other ones used by other tools, like HTC Sync. Nsight Tegra connects to an adb server via sockets to track devices and such conflicting instances might prevent it from detecting your device correctly. Please make sure that you don’t have any adb-using apps running at the same time as you work with Nsight Tegra.

You could also send me the logs from %AppData%\NVIDIA Corporation\Nsight Tegra\Logs, they might shed some light on the issue. See my email in a PM I’ve just sent you.

I was able to fix the issue and indeed it had something to do with 2 adb versions.
After deleting the adb version that wasn’t used by the tegra plugin, everything worked as expected.

Thanks for the help :)