with pgi/13.1 -ta=nvidia,time not working any more !

Hello .

I’ve installed the last pgi/13.1 .

The timing option for accelerator -ta=nvidia,time doesn’t work any more <=> doesn’t give kernel timing …

For examples with the samples accel coming with PGI .

pgfortran --version
pgfortran 13.1-1 64-bit target on x86-64 Linux -tp nehalem

pwd
/home/escj/dir_PGF/PGI_HOME/linux86-64/13.1/etc/samples/accel

make f3.time
...

f3.time
            0  errors found
        58859  microseconds on GPU
           71  microseconds on host

#Here NO timing !!!

The timing comeback setting the PGI_ACC_TIME=1 but it is not the expected functionality .

export PGI_ACC_TIME=1
 f3.time
            0  errors found
        61636  microseconds on GPU
           71  microseconds on host

Accelerator Kernel Timing data
/home/escj/dir_PGF/PGI_HOME/linux86-64/13.1/etc/samples/accel/f3.f90
  smooth  NVIDIA  devicenum=0
        time(us): 323
        24: data copyin reached 2 times
             device time(us): total=52 max=28 min=24 avg=26
        28: kernel launched 5 times
...

A+

Juan

Hi Juan,

The timing option for accelerator -ta=nvidia,time doesn’t work any more <=> doesn’t give kernel timing …

Correct. The “time” sub-option was deprecated in 12.x in favor of the “PGI_ACC_TIME” environment variable, and removed in 13.1 as we start to provide for support for more target devices beyond NVIDIA. The environment allows for more flexibility and does not require a recompile in order to enable/disable profiling.

  • Mat

Ok mat …
( … but the doc, man pgfortran or pgi131ug/rf.pdf doesn’t indicate deprecated a feature )

A+
Juan