With respect to size of outputfile related to 00_video_decode

Hello
Thank you for your answer.

$ ./video_decode H264 -o ./s.yuv …/…/data/Video/sample_outdoor_car_1080p_10fps.h264

The size of the output file s.yuv has been 1.8 gigabytes.
Can the capacity be reduced?
Are there any capacity options?

I would be grateful if you could give me a sample command when printing to yuv.

thank you.

Hi,
You may add logic of dumping single frame:

static  int dump = 1;
                /* Write raw video frame to file. */
                if (!ctx->stats && ctx->out_file && dump)
                {
                    /* Dumping two planes for NV12, NV16, NV24 and three for I420 */
                    dump_dmabuf(ctx->dst_dma_fd, 0, ctx->out_file);
                    dump_dmabuf(ctx->dst_dma_fd, 1, ctx->out_file);
                    if (ctx->out_pixfmt == 2)
                    {
                        dump_dmabuf(ctx->dst_dma_fd, 2, ctx->out_file);
                    }
dump = 0;
                }

I execute the following command:
./video_decode H264 …/…/data/Video/sample_outdoor_car_1080p_10fps.h264

An error message appears:

Set governor to performance before enabling profiler
Creating decoder in blocking mode
Opening in BLOCKING MODE
NvMMLiteOpen : Block : BlockType = 261
NVMEDIA: Reading vendor.tegra.display-size : status: 6
NvMMLiteBlockCreate : Block : BlockType = 261
Starting decoder capture loop thread
Video Resolution: 1920x1080
[INFO] (NvEglRenderer.cpp:109) Setting Screen width 1920 height 1080
line 1656:Input file read complete
Query and set capture successful
Segmentation fault (core dumped)

Hi, DaneLLL.

Where to insert this logic of dumping single frame?

in NVEglRenderer.cpp file?
jetson_multimedia_api\samples\common\classes\NvEglRenderer.cpp

Hi,

It is in video_decode_main.cpp. You can grep dump_dmabuf().

Hi,

It looks to be certain issue in your system image. It is default command and should work fine. You may re-flash through SDKManager and run the sample in

/usr/src/jetson_multimedia_api/samples/00_video_decode

Hi,DaneLLL:
Thank you for your reply!
I have a question to confirm with you:
I downloaded the sample code file from this connection[ L4T Jetson TX1 R28.3.2 Multimedia API].
Does it mean that my source code download is wrong?

My jetson nano configuration is as follows:
system:Ubuntu 18.04.4 LTS
jetpack:4.4 DP [ L4T 32.4.2 ]

Hi,

It is wrong. Now the samples are installed through SDKManager. After the installation, please check

/usr/src/jetson_multimedia_api/

Thanks!The sample is now working properly.
But,i used the jtop command to find that the hardware decoder was turned off and it seems to be decoding on the CPU.

Doesn’t this sample use a hardware decoder to decode the video file?

Hi,
Please use tegrastats.

2 Likes

Thank you very much!
I used the tegrastats command to find the hardware decoder running.

1 Like

Hi @Arvin,

Hi, have you tried to run jtop with sudo? I see from your screen you run it without.
Usually NVDEC is available on tegrastats only when you run with sudo.

1 Like

Hi,rbonghi:
Thank you for your warning!
Run jtop with sudo can see the hardware decoder working

1 Like

Ok!

I will fix the encoding lines with a message. The output on jtop (without sudo) is wrong.

1 Like