WK2124 SPI to UART JP4.6 work ok,but JP5.1 failed

Hi,everybody
I am now using the WK2124 chip and using it via SPI out of UART, which was fine when I was on JP4.6 version. But when I used the same device tree and driver file on JP5.1, this chip did not work and an error message appeared.I don’t know what is the reason.I have also looked at some related links, but the problem still arises.
I need help. Thank you.

error message

dtsi

I also made modifications according to the following information, and the result is the same error prompt


Hi sjz_shaohua,

Are you using the devkit or custom board for Xavier NX?

Could you help to verify with the latest JP5.1.2(R35.4.1)?

wkmic,wk2xxx_spi seems a custom driver.
Have you requested the latest driver for K5.10 from your vendor?
Please also share your driver and also the full dmesg for further check.

HI,KevinFFF
This is the driver file provided by the manufacturer, they have been adapted to K5.10.
wk2xxx_spi.txt (63.1 KB)

Please also share the full dmesg.

It seems failed in wk2xxx_probe() so that you could add more messages in the driver to debug.
Since I don’t have this SPI to UART device to reproduce the issue and verify locally,
I would suggest you could compare the probe process between JP4.6 and JP5.1.

Log information used by JP4.6 is ok.—log_ok.txt. And log_failed.txt is JP5.1.
log_failed.txt (64.9 KB)
log_ok.txt (65.4 KB)
Thanks.

hi,KevinFFF
I used GPIO01(GPIO3_PQ.05) as IRQ pin, but why is this pin used as pmc@c360000 in JP5.1.

c14ba1921484a0fe88414d4aa705e18

[   72.399666] The spi failed to read the register.!!!!

Please check which register could not be read.

Could you also try to modify the following line in device tree?

- irq_gpio = <&tegra_main_gpio TEGRA194_MAIN_GPIO(Q, 5) 0>;
+ irq_gpio = <&tegra_main_gpio TEGRA194_MAIN_GPIO(Q, 5) IRQ_TYPE_LEVEL_LOW>;

Hi KevinFFF
I modified irq_gpio according to your method, but it still doesn’t work. I want to know if there is any difference between the pin timing of SPI in K4.9 and K5.10.

Yes, the time gap of SPI data in K5.10 seems longer than in K4.9.
We are still checking this issue, but the SPI driver is different from yours.

Do you think the current wk2xxx_probe() failed caused from the timing issue?

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.