Wpesrc plugin crashes on Jetson Orin

• Hardware Platform (Jetson / GPU) Jetson Orin AGX 32GB DevKit
• DeepStream Version 6.2
• JetPack Version (valid for Jetson only) 5.1.1
• Issue Type bug
• How to reproduce the issue ? Install gst-plugins-bad and launch any gstreamer pipeline involving the wpesrc element. For example:

gst-launch-1.0 -v wpesrc location="https://gstreamer.freedesktop.org" ! gldownload ! nvvideoconvert ! nveglglessink

• Requirement details Install dependencies for wpesrc then install gst-plugins-bad

I am aware that this plugin is not provided by Nvidia and is part of the “bad” collection, however I am hoping someone may have gotten it working on Jetson hardware and could share how. When the plugin tries to request the Wayland display handle it causes a segfault on the Jetson hardware. I tried running it after launching the Weston Wayland server but got the same result.

Moving to Jetson forum for better support.

Since we don’t have experience about this plugin, would see if other users can share suggestion.

I have since found that the glimagesink plugin which is part of the base gstreamer plugins also crashes in Weston with the same error:
Failed to create window surface: EGL_BAD_ALLOC

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.