X configuration files and my dread

Hello all, bear with me hear, as I am new to some of this, but promise to give all requested details.

I was attempting to add an additional monitor to my computer set up, and used the x config file generated by nvidia to change to a new file. I then rebooted and am met with a black screen. I have spent the last 3 days learning about BIOS, UEFI, GRUB, etc to little avail. I am aware I am out of my zone here and would like some potential options. If at all possible I would like a solution that would not require dropping to root command terminal.

Some details about my system

Optiplex 9020 using Linux, Windows

Gnome shell

Again, I know little, but am determined to figure this out, so any help, or even a description of some of these elements would be great! I can give more info on system if needed since I’m new will only let me post one picture

This forum is not the correct one to answer this question but I’m not sure which forum is the correct one based on the information in the post.

Hi, I am moving this topic to the Linux category, hoping someone can chime in there.

Please run nvidia-bug-report.sh as root and attach the resulting nvidia-bug-report.log.gz file to your post.

Hi Generix and all others who find their way here, to my main man Generix we actually have a private conversation about this. I did as you asked and uninstalled and reinstalled the driver, everything was lookin okay for half a second until I noticed all my storage was being taken up by snaps? I attempted to clear some snap logs to free up space but the runfile I was given by another to accomplish this obviously was incorrect and I should not have trusted that external source, as now my system is giving several errors for systemctl services.

I have two options, boot through a kernel and change the parameters as you have previously instructed, this boots computer but it hangs on dell ubuntu loading screen, if i I try a normal boot, the terminal shows the output I will link in image. So I am “out” of storage which stops my ability to rewrite or move any files or really accomplish two much, I have a external hard drive I can move files on but I worry something is wrong in my configuration, as because of this. bad files/info is populating my available storage. This makes using the root terminal in recovery mode kernel hard as well.

So I am feeling a bit stuck, changing the. parameters is only half my battle at the moment, if I generate another nvidia log it will just be the same I have sent you, which I will attach here. If i change the parameter I cant boot far enough past the menu loading hang page to generate a new bug report showing I am indeed doing what you have asked with the parameters. Hopefully this makes sense, and if it doesnt let me know and I can reword to the best of my knowledge.
nvidia-bug-report.log (3.6 MB)


Please first enable log persistence:
https://gist.github.com/JPvRiel/b7c185833da32631fa6ce65b40836887#create-storage-and-enable-storage-location

then do a normal boot, reboot to recovery and create a new nvidia-bug-report.log.
Please also post the output of
df

Regenix I did as you asked in the recovery kernel and enabled log persistence, when I proceeded with the normal boot it just went to a single blinking dot

Am I able to turn off my computer now and reboot into recovery to generate a new bug report for you or will doing so just undo any work I have done and not save log persistence change?

Yes, you can now reboot to recovery and create a new log. If log enabling persistence worked, then it should contain logs from the failed boot.

okay powered down, powered back on, booted to. root shell of recovery and generated a new bug report, let me know if log persistance worked
nvidia-bug-report.log.gz (529.9 KB)
i also ran df before generating report see below

No, it didn’t work but this no wonder since your root fs is completely full. Nothing will work with that. Please check if this data is in your home directory:
du -s ~

sorry for cropped picture the number value for /root is 3428

Ok, sorry, forgot you are in the recovery console as root. Please check your normal home
du -s /home/<your username>


Okay done and also went a step further hoping that might help you

Your home directory only contains 135GB but 900GB are missing, so those should be somewhere in the system directory. Please check the /var directory.
du -s /var/*

realized ypu live in pretty diff time zone, woke up early to hopefully catch you more here ya go


looks like we found our culprit please advise

Looks like you got some log flooding. Just remorselessly delete the first level
sudo rm /var/log/*
and reboot, then check du -s /var/log again

So now back to log persistance step or heading in different direction now?

There still seems to be a lot of wasted space in the logfile directory, you should check where this comes from, du -s /var/log/*
At the same time, you could check if log persistence now works,
journalctl -b-1
should output something from the previos boot, no need to post that.
Please post the output of
grep -i Storage /etc/systemd/journald.conf


Ignore the picture of the log output, I hadn’t re done log persistance, I did so after and before running grep, also checked with command you gave me so persistent logs are good ! What’s next!!