X server crashed installing nvidia-390.87 driver on Ubuntu 16.04.5

Hello there,

I was redirected here after making a call to your technical department. I wish to install Quadro P620 driver on my Ubuntu 16.04.5. Processor details are: Dual AMD EPYC 7301 with onboard ASPEED AST2500 graphics.

I followed the exact steps detailed here: https://devtalk.nvidia.com/default/topic/878117/-solved-titan-x-for-cuda-7-5-login-loop-error-ubuntu-14-04-/

I installed the driver with options --no-opengl-files and selected ‘no’ when prompted to modify my xorg.conf.

The steps outlined are followed exactly, except for step 2, as I could not find a xorg.conf file and I do not know how to create one. So after installation, and reboot, I could not use NVIDIA as I guess the X server was not pointed to the right GPU.

To fix this, I created /usr/share/X11/xorg.config.d/xorg.conf (see attached). After this, I rebooted and the whole X server crashed.

All files are attached herein.

Any help will be greatly appreciated.

Cheers,
Gary

nvidia-installer.log (25.4 KB)
nvidia-bug-report.log.gz (97.1 KB)
Xorg.0_after.log (9.47 KB)
Xorg.0_before.log (48.2 KB)
nvidia-drm-outputclass.conf.log (489 Bytes)
xorg.conf.log (195 Bytes)

That thread is about not using the nvidia gpu for graphics, I suspect that’s not what you want?
If so,

  • uninstall the .run installer using --uninstall option
  • see if you can disable the onboard graphics or switch primary graphics in bios
  • hook up the monitor to a connector on the nvidia card
  • Add the ubuntu graphics drivers ppa: https://launchpad.net/~graphics-drivers/+archive/ubuntu/ppa
  • install the nvidia driver: sudo apt install nvidia-396
  • in your xorg.conf, replace
    BusID “PCI:21:0:0”
    with
    BusID “PCI:33:0:0”
    xorg.conf takes decimal values, lspci and else displays hex values.
  • see if you can disable the onboard graphics or switch primary graphics in bios
    From memory, I don’t think I’ve encountered such option in BIOS. Will double check and revert.

  • hook up the monitor to a connector on the nvidia card

  • Add the ubuntu graphics drivers ppa: https://launchpad.net/~graphics-drivers/+archive/ubuntu/ppa

  • install the nvidia driver: sudo apt install nvidia-396
    I have tried this method countless times before this, but I always got stuck with a login loop.

  • in your xorg.conf, replace
    BusID “PCI:21:0:0”
    with
    BusID “PCI:33:0:0”
    xorg.conf takes decimal values, lspci and else displays hex values.

If using that procedure does not resolve the issue, please attach a new nvidia-bug-report.log.gz while having the driver from the ubuntu ppa installed.

Hi generix,

Thanks for your prompt response. I have followed your procedures above, and managed to get the Quadro working. What I did:

  1. Clean install of Ubuntu 16.04.5
  2. Establish xorg.conf to point to the Quadro
  3. Remove nouveau driver
  4. Add the ubuntu graphics drivers ppa: https://launchpad.net/~graphics-drivers/+archive/ubuntu/ppa
  5. install the nvidia driver: sudo apt install nvidia-396
  6. Reboot and enter into BIOS to set "offboard" for VGA
  7. At this point, everything seems to be working fine and I manage to use the Quadro for display.

Now, I would like to ask if the procedures above include CUDA? I may want to use the Quadro for computation. Appreciate your help.

Cheers,
Gary

Cuda is not freely distributable, so this has to be downloaded from the nvidia site anyway.

  • Download the cuda 9.2 .deb package
  • follow the instructions to add it to your system
  • don’t do the last step to install cuda, instead, use sudo apt install cuda-toolkit-9-2

Just to confirm, the .deb package can be downloaded from here: https://developer.nvidia.com/cuda-92-download-archive?target_os=Linux&target_arch=x86_64&target_distro=Ubuntu&target_version=1604&target_type=deblocal

And the installation steps are:
sudo dpkg -i cuda-repo-ubuntu1604-9-2-local_9.2.148-1_amd64.deb
sudo apt-key add /var/cuda-repo-<version>/7fa2af80.pub where is “ubuntu1604-9-2-local_9.2.148-1_amd64”
sudo apt-get update
sudo apt-get install cuda-toolkit-9-2

Cheers