X Server crashes with Geforce 7100 and nvidia-304.131 driver on Ubuntu 14.04 LTS

Hi all,

I have an old Fujitsu Esprimo P2550 Desktop Tower (actually I have two identically constructed) which has an onboard NVidia VGA controller.

lspci -vnn |grep VGA -A 8

00:10.0 VGA compatible controller [0300]: NVIDIA Corporation C73 [GeForce 7100 / nForce 630i] [10de:07e1] (rev a2) (prog-if 00 [VGA controller])
	Subsystem: Fujitsu Technology Solutions Device [1734:115b]
	Flags: bus master, 66MHz, fast devsel, latency 0, IRQ 11
	Memory at fd000000 (32-bit, non-prefetchable) 
	Memory at e0000000 (64-bit, prefetchable) 
	Memory at fc000000 (64-bit, non-prefetchable) 
	[virtual] Expansion ROM at 80000000 [disabled] 
	Capabilities: <access denied>
	Kernel driver in use: nvidia

I installed Ubuntu 14.04 LTS and tried to configure the system with nouveau driver but the X server (and with that the whole system) froze immediatly after I tried to start any program. Switching to tty1-6 worked only, if the system was not frozen before.

Then I directly installed nvidia-304.131 (while first try some weeks ago it was .128).

After installing the nvidia driver the X Server does not worked anymore. Sometimes I saw the Desktop, but no button or keybord shortcut worked, the other times the screen was black. If the screen switched off and I woke up the system, the password promt was comming and I was able to login, but as before the Desktop was not working.

I tried to figure out, if it is an Ubuntu or a NVidia problem. Then I realized, that the gpu throws (beneath a lot of other XIDs) an XID 9 error in the kernel log. As described at http://docs.nvidia.com/deploy/xid-errors/ the XID 9 is an driver error.

Nevertheless I tried to use Ubuntu 15.04 with same result.

I did the whole stuff with the second tower and I had the same result.

I tried to play around with grub boot config and with X config, but nothing affects the problem.

Thank you in advance for any help.

PS. The script ‘nvidia-bug-report.sh’ does not read the ubuntu kernel log file, because that is named ‘kern.log’, but the script only looks for ‘messages’ and ‘kernel.log’ - To make this work, you need to add ‘/var/log/kern.log’ at line 469
nvidia-bug-report.log.gz (43.5 KB)


I believe I’m experiencing the exact same issues… I have a computer I use as a media center PC, and tried Ubuntu 16.04 as well as 14.04.
Both are very slow and sluggish with window animations, and opening certain programs will freeze the entire system requiring a hard reset.
I’ve tried installing the proprietary nvidia drivers via additional drivers, however after a reboot I either get a partially loaded desktop where no keyboard or mouse input is recognised (except moving the courser with the mouse), or no desktop at all.

The heck is going on here? lol

Any advice on this, and any solutions thus far?