X server failed to start after installing drivers without -no-opengl-files flag (Ubuntu 18.04 LTS, R...

Hello,

There is a fresh installed Ubuntu 18.04 LTS on my workstation and I’m experiencing problems when attempting to install drivers for my four RTX 2080 Ti cards. The X server did works when the drivers (418.56 or 430.26) was installed with -no-opengl-files, but llvmpipe was used as the OpenGL renderer. I’ve also tried to install the driver without any flags, but in this case X server cannot start, however, when I run startx as root, X server starts normally and OpenGL renderer is successfully switched to RTX 2080 Ti.

The drivers seemed to be always installed successfully as my programs and nvidia-smi runs well.

I’m still in my leave so I’m not able to upload any log file at this time, but I can remember that /var/log/Xorg.0.log said that “No input driver specified, ignoring this device” for the 4 cards and all GPU devices was deleted at the tail of the log.

Thank you.
nvidia-bug-report.log.gz (2.64 MB)
Xorg.0.log (38.7 KB)

Please run nvidia-bug-report.sh as root and attach the resulting .gz file to your post. Hovering the mouse over an existing post of yours will reveal a paperclip icon.
https://devtalk.nvidia.com/default/topic/1043347/announcements/attaching-files-to-forum-topics-posts/

Hello,

nvidia-bug-report.gz and Xorg.0.log have been uploaded. Thank you for your help.