X server fails with Quadro RTX 4000 on RHEL 8.2 driver 450.66

Unable to start x server after installing driver 450.66 on RHEL 8.2. The server has onboard VGA graphics, but am unable to get it use the Quardro RTX 4000 gpu. GPU shows up in lspci and BIOS is set to prioritize the GPU over the onboard VGA. I’ve attached the log file.

nvidia-bug-report.log.gz (901.5 KB)

It doesn’t look like prioritizing the Quadro worked:

[  5291.038] (--) PCI:*(3@0:0:0) 1a03:2000:1a03:2000 rev 65, Mem @ 0x9c000000/16777216, 0x9d000000/131072, I/O @ 0x00002000/128, BIOS @ 0x????????/131072
[  5291.038] (--) PCI: (59@0:0:0) 10de:1eb1:10de:12a0 rev 161, Mem @ 0xb7000000/16777216, 0x38bfe0000000/268435456, 0x38bff0000000/33554432, I/O @ 0x00007000/128, BIOS @ 0x????????/524288

The * there indicates that the onboard VGA device is primary.

Please try adding a BusID to the “Device0” section of /etc/X11/xorg.conf:

BusID "PCI:59:0:0"

That fixed it! Thanks for the quick reply

I’d like to try swapping in another GPU (Titan V) in this machine. What would the procedure be? Do I need to uninstall the driver, swap the cards, then reinstall the driver, or just swap the cards and update that xorg.conf file with a new BusID?