X11 not working after CUDA 7.5 installation

Hi all,
After installing CUDA, X stop working. How to fix this?

More details would be required to answer this. What GPUs are in your system? Which GPU did you intend to use for display?

HI,
I am using the Tesla M40 for compute and I want to use the onboard (AST driver) for display. X11 is functioning fine with out CUDA (Including uninstalling of CUDA 7.5). Here is what I did for the install:

zypper in cuda-toolkit-7-5 nvidia-computeG03 nvidia-gfxG03-kmp-default nvidia-uvm-gfxG03-kmp-default

#hwinfo --gfxcard
42: PCI 300.0: 0302 3D controller
[Created at pci.366]
Unique ID: svHJ.ycl7M6DWIgF
Parent ID: _Znp.m+lhhXe7gq5
SysFS ID: /devices/pci0000:00/0000:00:02.0/0000:03:00.0
SysFS BusID: 0000:03:00.0
Hardware Class: graphics card
Model: “nVidia 3D controller”
Vendor: pci 0x10de “nVidia Corporation”
Device: pci 0x17fd
SubVendor: pci 0x10de “nVidia Corporation”
SubDevice: pci 0x1171
Revision: 0xa1
Driver: “nvidia”
Driver Modules: “nvidia”
Memory Range: 0xd1000000-0xd1ffffff (rw,non-prefetchable)
Memory Range: 0x383800000000-0x383bffffffff (ro,non-prefetchable)
Memory Range: 0x383c00000000-0x383c01ffffff (ro,non-prefetchable)
IRQ: 32 (no events)
Module Alias: “pci:v000010DEd000017FDsv000010DEsd00001171bc03sc02i00”
Driver Info #0:
Driver Status: nvidia is active
Driver Activation Cmd: “modprobe nvidia”
Config Status: cfg=new, avail=yes, need=no, active=unknown
Attached to: #10 (PCI bridge)

44: PCI 700.0: 0300 VGA compatible controller (VGA)
[Created at pci.366]
Unique ID: aK5u.qkFhhmWwl9D
Parent ID: vTuk.NUOYMo113g8
SysFS ID: /devices/pci0000:00/0000:00:1c.3/0000:06:00.0/0000:07:00.0
SysFS BusID: 0000:07:00.0
Hardware Class: graphics card
Device Name: “ASPEED Video AST2400”
Model: “ASPEED AST1000/2000”
Vendor: pci 0x1a03 “ASPEED Technology Inc.”
Device: pci 0x2000 “AST1000/2000”
SubVendor: pci 0x15d9 “Super Micro Computer Inc”
SubDevice: pci 0x0852
Revision: 0x30
Driver: “ast”
Driver Modules: “drm”
Memory Range: 0xcf000000-0xcfffffff (rw,non-prefetchable)
Memory Range: 0xd0000000-0xd001ffff (rw,non-prefetchable)
I/O Ports: 0x5000-0x5fff (rw)
IRQ: 19 (no events)
I/O Ports: 0x3c0-0x3df (rw)
Module Alias: “pci:v00001A03d00002000sv000015D9sd00000852bc03sc00i00”
Driver Info #0:
XFree86 v4 Server Module: ast
Config Status: cfg=new, avail=yes, need=no, active=unknown
Attached to: #43 (PCI bridge)

Primary display adapter: #44

nvcc -V

nvcc: NVIDIA ® Cuda compiler driver
Copyright © 2005-2015 NVIDIA Corporation
Built on Tue_Aug_11_14:27:32_CDT_2015
Cuda compilation tools, release 7.5, V7.5.17

#cat /etc/X11/xorg.conf

nvidia-xconfig: X configuration file generated by nvidia-xconfig

nvidia-xconfig: version 352.39 (buildmeister@swio-display-x64-rhel04-18) Fri Aug 14 18:49:16 PDT 2015

Section “ServerLayout”
Identifier “Layout”
Screen “vesa” 0 0
InputDevice “Keyboard0” “CoreKeyboard”
InputDevice “Mouse0” “CorePointer”
EndSection

Section “InputDevice”
# generated from default
Identifier “Keyboard0”
Driver “keyboard”
EndSection

Section “InputDevice”
# generated from data in “/etc/sysconfig/mouse”
Identifier “Mouse0”
Driver “mouse”
Option “Protocol” “IMPS/2”
Option “Device” “/dev/input/mice”
Option “Emulate3Buttons” “yes”
Option “ZAxisMapping” “4 5”
EndSection

Section “Monitor”
Identifier “Monitor0”
VendorName “Unknown”
ModelName “Unknown”
HorizSync 28.0 - 33.0
VertRefresh 43.0 - 72.0
#Option “DPMS”
EndSection

Section “Device”
Identifier “vesa”
Driver “ast”
BusID “PCI:7:00:0”
EndSection

Section “Screen”
Identifier “vesa”
Device “vesa”
Monitor “Monitor0”
DefaultDepth 24
SubSection “Display”
Depth 24
Modes “auto-select”
EndSubSection
EndSection

That install method doesn’t reflect anything I’m familiar with.

I suggest you carefully follow the instructions in the CUDA linux install guide.

Furthermore, to avoid the NVIDIA driver affecting your non-NVIDIA X graphics stack, I would suggest installing the driver separately, and passing necessary switches to the driver installer to skip the installation of OpenGL libraries. It is the install of these OpenGL libraries by the driver installer (necessary if you were going to use an NVIDIA GPU for display) that are corrupting your non-NVIDIA X stack.

  1. From a clean OS load, install the NVIDIA driver, but pass the switches to skip install of the OpenGL libs.
  2. For the remainder, follow the instructions in the linux install guide, but select “no” when prompted to install the driver.

For item 1, instructions are covered here:

https://devtalk.nvidia.com/default/topic/878117/-solved-titan-x-for-cuda-7-5-login-loop-error-ubuntu-14-04-/

For item 2, the CUDA 7.5 linux install guide is here:

http://docs.nvidia.com/cuda/cuda-installation-guide-linux/index.html#abstract