Xavier 10Gb Ethernet (Solved)

Any recommendations on using Xavier with 10Gb Ethernet? Thought about using PCIe card but doesn’t seem very substantial with cables attached.

The PCIe card on the devkit is the only way to get it in there without custom hardware.
(There are no M.2 10 Gb cards that I know of.)

You can build your own bracket and affix it to the devkit if you’re worried about putting too much stress on things. A little 16 gauge mild steel strip, bend it in a vise or across a sharp edge, drill and tap a hole in the right place, apply glue to heatsink, done!
Or if you prefer, just 3D print something.

Any suggestions for a PCIe 10 Gb Ethernet card to use with Xavier? I’ve seen a couple posts in these forums that indicate Intel X540/550 based cards should work, but nothing definitive. What would need to be done to install/enable the driver?

Any confirmed performance > 1 Gb/s?


Hi TroyK,

Intel X540T2 should work. Please check it on your side.
If hitting any problem, please let us know.

Hi WayneWWW:

Unfortunately the device we’re trying to talk to requires the coax connector so we’re using an X520-DA2 card. We have used the card successfully in another machine talking to the same device with the same cables so we think it should work, but it won’t go faster than 1Gb/sec on the Xavier. We tried an alternative card from another machine & the problem was still there.


  • JLW

We are out of the NIC for test right now. Once we get back the device, we will share the test result.

Hi all,
I’m using the Xavier dev kit in combination with an intel X520-DA2 card to talk with a software defined radio (Ettus USRP X300) over 10Gbe. The driver for the card seems to already be present in the OS as I can see the interfaces launching ifconfig however there is no way to communicate with the SDR (except for pinging and device discovery). Downloading the comprehensive driver pack from Intel does not help as it doesn’t compile. I also tried a Mellanox CX512A but the ofed driver does not compile (I’m opening an other topic about this)

Any information would be appreciated.


Have you read L4T document to confirm the way you compile the driver?