Xavier A stuck while booting

Dear @alaa.mahdy,
You can flash only Xavier A using sdkmanager. You would notice drop down menu to select Flash Xavier A+B/Flash Xavier A/ Flash Xavier B at the time of flashing in the end of step 3(Install DRIVE with SDK Manager :: NVIDIA SDK Manager Documentation)

Dear Siva

For some reason I don’t have this option. I am currently using SDK manager version 1.5.0.7774. Please check the following screenshot

I tried to reflash both SoCs in parallel and now both of them are stuck, Xavier B is now showing the following error in minicom which indicates that image verification is failing

I triggered flashing for the third time, i hope it recovers the kit

Third flashing attempt also failed on both SoCs, please check the attached traces

TegraBLog_ogQHLPNJ8G.txt (24.8 KB)
TegraALog_bOZdqI25uY.txt (19.3 KB)

Dear @alaa.mahdy,
For some reason I don’t have this option

This is strange. You can confirm the version with sdkmanager --ver as I don’t see sdmanager version in GUI. I think it could be due to system resolution due to which you might not be seeing text after Flash. Please check changing resolution and see if other flashing options available.

Could you attach the latest complete logs in ~/.nvsdkm/logs/ folder and ~/.nvsdkm/sdkm*.log

The version is shown in the upper left corner of the following screenshot

sdkm-2021-06-01-13-45-40.log (38.2 KB)

Dear @alaa.mahdy,
Could you share ~/.nvsdkm/logs folder as requested earlier.

Dear Siva

Please find the logs attached, please note that i have two installations
(DRIVE Software 10.0 and DRIVE OS 5.2) I am only trying to to flash DRIVE Software 10.0

logs.zip (610.6 KB)

Dear @alaa.mahdy,
I notice cannot remove '/home/amahdy/nvidia/nvidia_sdk/DRIVE_Software_10.0_Linux_OS_DDPX/DRIVEOS/drive-t186ref-foundation/tools/host/flashtools/bootburn_t19x/_temp_dump/_temp_dump_xxNg1qqwid/flash-images': Directory not empty error in NV_FLASH_XAVIER_PDKFLASH_PARALLEL_COMP.log. Could you check deleting those temp folder and check flashing again

Dear Siva

I changed the resolution however i am still not seeing options to flash Xavier A/B independently

I tried to remove the folder and reflash however flashing is still failing at the same point

TegraALog_4Uc020qhbN.txt (19.3 KB)
TegraBLog_xDoBEo8HFc.txt (21.6 KB)

XA seem to be not responding to ADB, the following is part of the attached trace TegraALog_…

Android Debug Bridge version 1.0.36
Revision -android
Platform version 7.0
supports 262144 Bytes MAX_PAYLOAD
This build is for NVIDIA embedded bootburn
Build time : May 16 2017 01:26:13
serial number to adb : 2P1101020000001G30K0
Could not find a device online

Now when i try to boot I get the following trace on the minicom terminals (XB on the left side and XA on the right side)

Can the board be reflashed in this state ? or i need to perform some special steps

Hello Siva

Any updates regarding the questions in the previous post? we are currently blocked

Hi @alaa.mahdy ,

Are you using USB 2.0 Type A to Type A cable? 3.0 isn’t supported.

Hello Vick

I am using the cable provided with the Kit, I don’t see how this is relevant to the issue I am facing.

Currently both SoCs are not booting as shown in the screen shots in my previous post, XA seems to be stuck at a very early stage and this would explain why it is not responding to ADB

Flashing seems to be consistently failing at the same point as shown in the logs attached in the previous post

Please refer to the following topic and see if using another USB 2.0 Type A to Type A cable (not too long) will help on your issue. Thanks.

Hi Vick

I checked again and found that I am already using a USB2.0 Type A cable (~2 meters long), this is the cable delivered with the kit. Do I need to use a shorter USB2.0 cable ? also do I need to apply the DTB patch provided in the other thread ?

Hi Vick, Siva

I will try a shorter cable to see if it would fix the flashing issue for the XavierB side

For XavierA it seems I may have a different issue. From the boot trace i can see the following error messages

[0001.879] E> WP-1 ACK pending
[0001.882] E> Error: 0
[0001.884] E> Task 71 failed (err: 0x32320006)
[0001.888] E> Top caller module: CPUINIT, error module: CPUINIT, reason: 0x06, aux_info: 0x00

and by checking other threads in the forum it seems that I may have an issue with the PMIC since it seems to be not responding with an ACK. I think this would explain why Xavier A is not responding to the bootburn via ADB because it stuck at a very early stage

Any suggestions on how to proceed ?

If you use the cable delivered with the kit (supposedly USB 2.0 Type A to Type A one), you don’t need to apply the patch.

Let’s focus on the flashing problem first.
According to your logs, your problem (“Could not find a device online” in flashing Xavier A) looks the same as the other topic.
Besides replacing with another USB 2.0 Type A to Type A cable, could you also try with anything related to USB connection? e.g. connecting to another port on your host system, use another host system.

Also, please confirm if you use native Ubuntu 18.04 host system, not vm one.

I am using a Native Ubuntu 18.04 host system not a VM

I ordered a new USB cable USB2.0 A/A (30 cm long) and will receive it by Monday, my host only have a single USB port type A, I will see if I can try another environment

1 Like