Xavier AGX can not shutdown because I210 WoL

Hi all

Platform: Xavier AGX
Jetpack : 5.0.2

I have issue on Xavier AGX with Jetpack 5.0.2.

When I210 WoL enable can’t shutdown Xavier AGX , during shutdown debug port will show below information:
WARNING @ [platform/drivers/mailbox/mail_routing_layer/mail_routing_layer.c]: mail rx timeout
WARNING @ [platform/drivers/mailbox/tmo_link_provider/mail_tmo.c]: mail tmo TX timeout
WARNING @ [platform/drivers/mailbox/tmo_link_provider/mail_tmo.c]: mail tmo TX timeout
WARNING @ [platform/drivers/mailbox/tmo_link_provider/mail_tmo.c]: mail tmo TX timeout
WARNING @ [platform/drivers/mailbox/tmo_link_provider/mail_tmo.c]: mail tmo TX timeout

2 minute ~ 3 minute will auto reboot Platform.

If we use “ethtool -s eth0 wol d” disable WoL can fix this question. but I don’t know that is root cause? or can fix with other patch?

My status similar below website , however, does turning off PCIe’s shutdown power processing really not cause other side effect?

Please try to use jp5.1.2. JP5.0.2 is already too old to check anything.

HI Wayne

We can certaionly try to verify if Jetpack 5.1.2 has this issue.

However , our customers are already using Jetpack 5.0.2 . If they have to wait for Jetpack 5.1.2 to be revised , they must go through many verification processes again.

Practically speaking it doesn’t seem feasible right now…

Ok, then just follow above link to bypass this issue.

Sorry , I forgot to mention that the problem that we cannot shut down the computer only occurs when we use the “jetson_clocks” command to increase the frequency to the maximum.

Using jetson_clocks is only one of the conditions, not a solution.

This problem will occur when the system adjusts the frequency to the maximum value through jetson_clocks and does not turn off the I210’s wol.

I suspect that jetson_clocks turns off the power saving mechanism, causing some power management in the Kernel to fail, which ultimately leads to this problem.