Xavier AGX setup problems after flashing with SDK Manager

Hi all,

I have been trying to set up three XavierAGX with little success. While I am able to flash the OS on the target device, after the Nvidia SDK asks you to configure the OS problems arise. In particular, I have tried different configurations, each one giving different errors. To sum up the different trials and better know how to set up the devices I have read the forums, didn’t find anything that solved the problem. Hereby mi questions:

  • First the OS is flashed. Before this, proxy is configured on the host. This step is done by USB-C?
  • Then, you configure password and, in my case, the apt proxy on the target. Then, Jetson SDK components are installed via USB-C too? At this point, I have found many problems, even If I try different answers to previous post with similar problems.

PD: JetPack version is 4.5 or 4.5.1

Thank you in advance
Pablo, PhD. Student

Flash is always with the Xavier in recovery mode, and the USB-C cable connected to host PC. Once flash completes the Xavier will self-reboot, and then you’ll need to add a user login account prior to any packages being added (the packages install over ssh, and without an admin login SDKM cannot install anything).

Any network will work, but the virtual wired ethernet which appears on the USB-C cable is the default. What happens, when fully booted, is that the Xavier will look like it is a router to the host PC. If and only if the host PC does not stop use of that virtual device (such as because of security settings), then the virtual wired ethernet device will be used. The DHCP server of the virtual wired ethernet will assign address “” to the Jetson, and “” to the host PC. Thus, if it works, then from the host you could “ping”.

If host PC security is in the way, then you could monitor “dmesg --follow”, and plug in the USB-C. You’d see the virtual device, and you’d see the MAC address of that device. Then, using whatever network setup program available on the PC, you’d mark that MAC address as allowed. I prefer to use “nm-connection-editor” for this, but there are a lot of other choices as well (if you want that application, and it isn’t already there, then you could run “sudo apt-get install network-manager-gnome”).

Note that any network connection will work, e.g., you could connect both the host PC and the Jetson to the same router, and use whatever address your router assigns (check with “ifconfig”). You’d then change what the default is ( in the JetPack/SDK Manager app, and that address would be used instead.

Regardless of which address you use, you should be able to “ping ...that address...”, and also use ssh to log in to the admin user name at that address.

The steps are:

Flash the board (install the OS) → configure the user account (either headless method or through monitor) → After the account/pwd are set, the system will allow you to access through ssh → Jetpack/Sdkmanager are able to use ssh to install the SDK now.

The “headless” method to confgiure user account is through the port you used for flashing device.

Thank you both, I have repeated the process following the provided steps (summarized by WayneWWW). However, I am still in the same point of my original post.
I have found that the problem may be the proxy. I have set up the proxy both in the host computer (bashrc, /etc/environment, apt.conf/proxy.conf), Nvidia SDK (SDK Manager Settings :: NVIDIA SDK Manager Documentation) and the newly flashed XavierAGX (bashrc, /etc/environment, /apt.conf/proxy.conf).
Is there something I am missing?

Thank you in advance.

PD: I attach the logs, although I am pretty sure the first issue to solve is the proxy.

SDKM_logs_JetPack_4.5.1_Linux_for_Jetson_AGX_Xavier_2021-04-29_16-25-36.zip (141.4 KB)

One important question: If you have a proxy, then this would definitely have an effect on outside world network traffic. However, does your Jetson and the host PC share the same router without having to go through a proxy? If they share without anything interfering it is much simpler. If the two are on different networks and you use wired ethernet instead the virtual ethernet over USB, then the issues would change.

I’m pretty sure that the Jetson and the host PC are connected to the same router, and that the proxy is located between them and the outside world network traffic.

The configuration is as follows:
Jetson by USB-C to Host PC, Host-PC to the network by Ethernet.
The host PC is able to run apt commands correctly. However, sometimes I have found errors in the NVIDIA SDK login, and had to choose the “offline” option.

You are probably on the right track to consider this a proxy issue, and since you are using the USB-C virtual wired ethernet, then the Jetson probably does not need special settings if the host PC is itself configured correctly for the proxy (but I won’t guarantee that, things can go wrong). Someone else may be able to debug the SDKM logs, but I don’t know enough about it to guess on specifics relative to a proxy.

Thanks anyway, you helped me a lot linuxdev.