Xavier AGX USB-C port apparantly broken



Our Xavier AGX Dev Kit has the front USB (the is used for flashing) apparently dead. It used to work before flashing to:

R35 (release), REVISION: 1.0, GCID: 31346300, BOARD: t186ref, EABI: aarch64, DATE: Thu Aug

Why do I say it’s apparently dead? dmesg --follow shows nothing when I connect or disconnect. Even, when I connect micro-USB debug port to my pc, I can see messages when attaching devices to the other USB ports, but not the apparently broken one.

Note: Power On Led is also not as bright as usual. Maybe a power problem?


To tell whether this is software issue or hardware, could you also try rel-32 jetpack release too?

I’ve checked. jetpack 32 worked. And I have flashed again with 35 and now it works. I don’t know what could happen to previous installation. Or maybe now the drivers of the latest download are slightly different?

Nope, the driver won’t change.

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.