Xavier benchmark

Env:

  • Xavier
  • Jetpack 4.1
  1. How to execute trtexec in fp16 to benchmark xavier with ssd_mobilenet_v2(300×300), openpose(256×256) and Tiny YOLO V3(416×416)?

2.Where to download the above mode files?

Hi @thhsiao, for latest benchmarks, it is recommended to use https://github.com/NVIDIA-AI-IOT/jetson_benchmarks

Hi Dusty_nv
thanks for your info.
I have completed the installation, but there are 2 issues:

  1. Three files cannot be downloaded when I run
    sudo python3 utils/download_models.py --all --csv_file_path /home/nvidia/jetson_benchmarks/benchmark_csv/xavier-benchmarks.csv --save_dir /home/nvidia/jetson_benchmarks/models
    (1).super_resolution_bsd500.zip
    (2).yolov3-tiny-416.zip
    (3). ssd-mobilenet-v1.zip
    How to get the above files?

  2. Benchmarking fail due to write permission denied.
    When I run sudo python3 benchmark.py --model_name unet --csv_file_path ./benchmark_csv/xavier-benchmarks.csv --model_dir /home/nvidia/jetson_benchmarks/models

It display :
sh: 1: cannot create /sys/devices/pwm-fan/target_pwm: Permission denied
------------Executing unet-segmentation------------

Error in Build, Please check the log in: /home/nvidia/jetson_benchmarks/models
We recommend to run benchmarking in headless mode

P.S.
each folder in /sys/devices/pwm-fan/ are chmod to drwxr-xr-x.
,but situation is same as above.

Hi @thhsiao, I just double-checked and was able to download these ok, perhaps you might want to try again or maybe it’s a network issue since you were able to download the other files ok?

As listed in the GitHub, these benchmarks were developed/tested for JetPack 4.4, so you may need to upgrade JetPack version first.

Hi Dusty_nv

  1. Does upgrade JetPack version can keep the source codes I have build on it? or upgrade is same as reinstall will clean and create new OS?

  2. “Three files cannot be downloaded”, I mean all files can be downloaded except this three file.

If you are on JetPack 4.1, then it will require a re-flash and will create a new OS, so you should backup any files beforehand. But once you are re-flashed with JetPack 4.4, for future upgrades you will be able to use sudo apt-get upgrade without having to re-flash.