Xavier Debug UART only works with HDMI connected

We are using a custom carrier for the AGX Xavier. The board is very minimal and only has the debug port (UART3) and an HDMI (HDMI_DP2). The system has some very strange behaviour with the debug output. When the HDMI cable is connected to a display at boot, the uart works as expected. When the HDMI and display are disconnected at boot, the UART shows nothing. Any assistance would be appreciated. We suspect this could be a dts change that needs to be made.

hello sysopinit,

it’s by default using combined uart TCU for sending logs.
may I know what’s the real use-case, is there boot hang? please have a try to modify flash configuration file to disable console printing.
for example,
CMDLINE_ADD=“console=ttyTCU0,115200n8 console=tty0 fbcon=map:0 net.ifnames=0 rootfstype=ext4”;

Hi JerryChang
The boot does not hang and there is output on the HDMI and UART when HDMI is connected. When HDMI is disconnected, the Xavier boots but the UART shows no output/console. Do we need to disable combined-uart or redirect the console?

We tried the modification to the flash config you suggested, and UART is still not functional when HDMI is not connected. We have also verified that the module is booting completly when the display is not connected.

hello blokeandsally,

may I also know which JetPack release you’re using.
let me confirm the issue, did you meant you’ve setup a serial console through port J501 micro USB. but, it’s not functional after HDMI display is disconnected?

Hi JerryChang

We have had the same issue with JP 4.6.3 and 5.0.2.

Our custom board makes use of the rx (K60) / tx (H62) lines from what would be J501 (UART3 debug uart) and is exposed with a pin header on the board (not micro-USB). We do NOT run the rx (K60) / tx (H62) to an ftdi onboard and use and external serial-usb adapter.

We can see the boot/kernel logs and getty starts on the UART when HDMI is connected at boot but the UART has no output when HDMI is disconnected.

I’m closing this topic due to there is no update from you for a period, assuming this issue was resolved.
If still need the support, please open a new topic. Thanks

hello blokeandsally/sysopinit,

can you repo this on DevKit?
we’re all using J501 micro usb port for debug uart on Xavier developer kit, and we don’t see issues with JP-5.0.2 and JP-4.X with/without HDMI.