Xavier Dev Kit not boot up with the power cable in box

Please provide the following info (check/uncheck the boxes after clicking “+ Create Topic”):
Software Version
DRIVE OS Linux 5.2.0
DRIVE OS Linux 5.2.0 and DriveWorks 3.5
NVIDIA DRIVE™ Software 10.0 (Linux)
NVIDIA DRIVE™ Software 9.0 (Linux)
other DRIVE OS version

Target Operating System

Hardware Platform
NVIDIA DRIVE™ AGX Xavier DevKit (E3550)
NVIDIA DRIVE™ AGX Pegasus DevKit (E3550)

SDK Manager Version

Host Machine Version
native Ubuntu 18.04

I have received two Xavier Dev Kit (EKU 2000) devices and I tried to set them up. I ran into problems on the power supply cables. It seems I could not get the devices power on with the included power cables with one connector. I did try the cables with two connectors which came with previous Pegasus devices (EKU 2200) and the Xavier devices were able to boot up without problem.

Could you please let me know how to proceed to solve this problem? I could not use the two-connector power cable since they are needed for Pegasus.

I attached two pictures with the two connector cable (good) and one connector cable (bad, comes with the new purchase).

Hi @VerySimple ,

Did you turn on the power supply? Did you hear the fan sound? Is it possible to try with the power supply of the working one?

Thanks for asking. I have used Pegasus Dev Kit for long time. I know how to turn on the power supply. Please see my original post, I have tried to replace the power cable comes with Pegasus on this Xavier dev kit and it worked. It is clear something wrong with the power cable comes with Xavier dev kit. One diff between them, is the cable comes with Xavier, has single connection header, while the one from Pegasus (which is working for me) is dual header.

We will check internally and get back to you. Thanks.

Let me clarify further. Do both “Vehicle Cable Harness for DRIVE
AGX Xavier Developer Kit” with the two new systems have the problem?

Neither of cables from both Xavier Dev Kits boxes work for the Devices (not boot up, the power unit fan worked but not the Xavier fan). With the old cables (with dual headers) from our pervious Pegasus dev kit, we were able to boot the newly purchased Xavier dev kits.

We’ll check with the internal team about the verification of the two devkits and get back to you. Thanks.

Please double-check if the MCU Programming Switch, on the platform harness, is set to the PRG position.

If it doesn’t help, please do the following test:

  1. Swap the harness cables. Connect the MAIN harness connector (bad, comes with the new purchase) to the Pegasus Dev Kit (SKU 2200), and connect the MAIN harness connector (good, comes with the previous Pegasus) to the Xavier Dev Kit (SKU 2000).
  2. Capture the boot logs on Aurix/XA/XB consoles.
1 Like

Yes the MCU Programming Switch was set to PRG. After I switch it back to RUN, I am able to boot up the devices. Not sure why and how this switch was set to PRG our of the box. Anyway, the mystery is solved and thanks a lot!

Thanks for letting us know.