Xavier hangs after flashing


after flashing JetPack 4.3 (32.3.1) to our Xavier AGX and entering all the details on the device itself for getting Ubuntu started, the device restarts, but hangs at the end on this screen which is flashing on and off: https://imgur.com/a/bxtQuRC

At the beginning it also shows the following “FAILED” message: https://imgur.com/a/ToXrPBz

I’m not getting to a login screen at all. I tried re-flashing, but the problems keeps to be the same. Sometimes it hangs with a different last line, but the FAILED messages are always the same.

Any idea what I can do?

I see one case of permissions issue. Was this flashed from a host PC with ext4 filesystem? Did you use command line, or did you use JetPack/SDK Manager? Which release was flashed?

We were using the newest version of the SDK manager on a ubuntu 18.04 machine with ext4 file system. After flashing followed by system setup on the Xavier, ubuntu wants to reboot and then this situation arises.

Fun fact: we had managed to flash and run the system before. We needed to re-flash the system because of some driver mess-up, and now we have this phenomenon.

Is anything at all custom about this system? I’m thinking that perhaps the kernel and/or device tree was modified and that the CONFIG_LOCALVERSION did not match the previous kernel…which in turn would cause modules to not be found unless you added those modules yourself. Keep in mind that if you’ve modified the kernel within the sample rootfs or the subdirectories of “Linux_for_Tegra/” on the host PC, then those changes might be persistent. If instead there was no modification, then this looks more like a hardware issue.

We actually had 2 problems:

  1. We have this HDMI/USB switch attached to the board (we have many of them). At first Boot time, the board did not have connection to a monitor. But it still wouldn’t boot after re-flashing
  2. Found out we had tried to install a Leopard-Imaging Camera/MIPI driver which patches the files on the host machine before the actual flashing process. These files were messed up.

After fixing these 2, the device works again. … But not with the LI camera…

Thanks for your help.

you may get assistance with LI from LI support;
they have documented instructions and modified software that needs to be installed according to the instructions in order to get cameras working, as far as I know

i did. they said they will have 4.3 drivers ready in April.