Xavier industrial no disaply spi node

Hi,
I configured spi functionality on a custom carrier board, However, the system does not display the SPI node.


spi@c260000 {
//status = “disabled”;
status = “okay”;
spi@0 {
compatible = “tegra-spidev”;
reg = <0x0>;
spi-max-frequency = <33000000>;
controller-data {
nvidia,enable-hw-based-cs;
nvidia,rx-clk-tap-delay = <0x11>;
};
};
};

    spi@3210000 {
            //status = "okay";
            status = "disabled";
            /*spi@0 {
                    compatible = "tegra-spidev";
                    reg = <0x0>;
                    spi-max-frequency = <33000000>;
                    controller-data {
                            nvidia,enable-hw-based-cs;
                            nvidia,rx-clk-tap-delay = <0x11>;
                    };
            };
            spi@1 {
                    compatible = "tegra-spidev";
                    reg = <0x1>;
                    spi-max-frequency = <33000000>;
                    controller-data {
                            nvidia,enable-hw-based-cs;
                            nvidia,rx-clk-tap-delay = <0x11>;
                    };
            };*/
    };

Try below command after boot to system.

sudo modprobe spidev.ko

Thank you very much. After loading the driver, the node is displayed.

In jetpack 4.6 previous versions, this driver is loaded automatically. What happens to this version (jetpack 4.6)?

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.