Hi everyone.
Our current hardware design about camera is imx390+ UB953( Ti Ser) +UB960(Ti Des).
The imx390 RAW12 image data output format:

We read 1098 lines from UB960,but we want 1080 lines,the other 18 lines are Front Embedded Data Line(1) + Ignored OB(2) + Vertical effective OB(10) + SMPG(4) + Rear Embedded Data line (1);
We try to modify the device tree as follows:
active_w = “1920”;
active_h = “1098”;
embedded_metadata_height = “1”;
num_of_ignored_lines = “12”;
But it didn’t seem to work.

We try to use this command:v4l2-ctl -d /dev/video1 --set-fmt-video=width=1920,height=1098,pixelformat=RG12 --set-ctrl bypass_mode=0 --stream-mmap --stream-count=1 --stream-to=test.raw
The result of the error is:
kworker/0:3-2031 [000] … 118.743473: rtcpu_vinotify_event: tstamp:3898588324 tag:FS channel:0x01 frame:3 vi_tstamp:3898578436 data:0x00000010
kworker/0:3-2031 [000] … 118.743473: rtcpu_vinotify_event: tstamp:3898588472 tag:ATOMP_FS channel:0x00 frame:3 vi_tstamp:3898578440 data:0x00000000
kworker/0:3-2031 [000] … 118.743474: rtcpu_vinotify_event: tstamp:3898588599 tag:CHANSEL_FAULT channel:0x23 frame:3 vi_tstamp:3898579250 data:0x00004004
kworker/0:3-2031 [000] … 118.743475: rtcpu_vinotify_event: tstamp:3898588743 tag:RESERVED_19 channel:0x23 frame:3 vi_tstamp:4495459520 data:0x01020075
kworker/0:3-2031 [000] … 118.743476: rtcpu_vinotify_event: tstamp:3898588868 tag:CHANSEL_NOMATCH channel:0x41 frame:3 vi_tstamp:3898580639 data:0x000006e9
kworker/0:3-2031 [000] … 118.743478: rtos_queue_send_from_isr_failed: tstamp:3898603066 queue:0x0bcb41f8
kworker/0:3-2031 [000] … 118.743479: rtos_queue_send_from_isr_failed: tstamp:3898603209 queue:0x0bcb8a60
kworker/0:3-2031 [000] … 118.743480: rtos_queue_send_from_isr_failed: tstamp:3898603346 queue:0x0bcba5e0
kworker/0:3-2031 [000] … 118.743481: rtos_queue_send_from_isr_failed: tstamp:3898603480 queue:0x0bcbb3a0
kworker/0:3-2031 [000] … 118.743482: rtos_queue_send_from_isr_failed: tstamp:3898603612 queue:0x0bcbc160
kworker/0:3-2031 [000] … 118.743483: rtcpu_vinotify_event: tstamp:3899098593 tag:CHANSEL_FAULT channel:0x23 frame:3 vi_tstamp:3898588970 data:0x00004001
kworker/0:3-2031 [000] … 118.743484: rtcpu_vinotify_event: tstamp:3899098721 tag:RESERVED_19 channel:0x23 frame:3 vi_tstamp:4495771168 data:0x01020075
kworker/0:3-2031 [000] … 118.743485: rtcpu_vinotify_event: tstamp:3899098865 tag:FE channel:0x01 frame:3 vi_tstamp:3899094638 data:0x00000020
kworker/0:3-2031 [000] … 118.743486: rtcpu_vinotify_event: tstamp:3899098992 tag:CHANSEL_SHORT_FRAME channel:0x41 frame:3 vi_tstamp:3899094638 data:0x00000000
kworker/0:3-2031 [000] … 118.743486: rtcpu_vinotify_event: tstamp:3899099152 tag:RESERVED_19 channel:0x23 frame:3 vi_tstamp:4511963584 data:0x01020075
kworker/0:3-2031 [000] … 118.743487: rtcpu_vinotify_event: tstamp:3899099276 tag:CHANSEL_SHORT_FRAME channel:0x41 frame:3 vi_tstamp:3899094638 data:0x01000000
kworker/0:3-2031 [000] … 118.799398: rtcpu_vinotify_event: tstamp:3899617917 tag:RESERVED_19 channel:0x23 frame:3 vi_tstamp:4511986240 data:0x01020075
kworker/0:3-2031 [000] … 118.799402: rtcpu_vinotify_event: tstamp:3899618044 tag:ATOMP_FE channel:0x00 frame:3 vi_tstamp:3899094640 data:0x00000000
kworker/0:3-2031 [000] … 118.799403: rtcpu_vinotify_event: tstamp:3899618204 tag:RESERVED_19 channel:0x23 frame:0 vi_tstamp:4512001504 data:0x07020076
kworker/0:3-2031 [000] … 118.799404: rtcpu_vinotify_event: tstamp:3899618326 tag:RESERVED_18 channel:0x23 frame:0 vi_tstamp:4512123456 data:0x10000000
kworker/0:3-2031 [000] … 118.799405: rtcpu_vinotify_event: tstamp:3899618480 tag:RESERVED_18 channel:0x23 frame:0 vi_tstamp:4512153152 data:0x31000077

How to solve these data Front Embedded Data Line(1) + Ignored OB(2) + Vertical effective OB(10) + SMPG(4) + Rear Embedded Data line (1).

Look forward to answers.

Welcome to Jetson & Embedded Systems forum, please be more specific of your issue, then we can know how to support you.

Thanks for your reply,some instructions have been added. We’ve already worked on other cameras,
but the imx390 hasn’t worked yet, Looking forward to your help.

Could you try the default driver setting and device tree?


Hello ShaneCCC,
Thanks for your reply, I followed your suggestion, but no luck, The imx390 is not working at all.
I follow the configuration provided by Sony,We read 1098 lines from UB960, the other 18 lines are Front Embedded Data Line(1) + Ignored OB(2) + Vertical effective OB(10) + SMPG(4) + Rear Embedded Data line (1), I don’t know how to deal with this extra data.
Look forward to answers.

What’s the trace log for the default driver configure?

Thank you very much. I just tried again, The default configuration can receive the graph, I’ll compare the default configuration with the one given by Sony.

1 Like