Xavier NX boot-up stuck after flash

Hello nVidia support,

After making some simple change to GPIO pin(simply set some pin output 1), I used the spreadsheet to generate the .dtsi files, then convert to .cfg files.

Then build the complete system kernel and dtb files.

./flash jetson-xavier-nx-devkit internal

after the system was flashed, during reboot, the system got stuck at:

L4TLauncher: Attempting GRUB boot
L4TLauncher:Attemping Direct Boot
EFI stub: Booting Linux Kernel…
EFI stub: Using DTB from configuration table
EFI stub: Loaded initrd from LINUX_EFI_INITRD_MEDIA_GUID device path
EFI stub: Exiting boot services and installing virtual address map… (it got stuck here).

it NEVER run into this line of code:
[ 0.000000] Booting Linux on physical CPU 0x0000000000 [0x4e0f0040]

at this point, the keyboard does not work either(the NumLock does not light up).

Note that:

during apply_binary.sh, it created a extlinux.conf file as below:

LABEL primary
MENU LABEL primary kernel
LINUX /boot/Image
FDT /boot/dtb/kernel_tegra194-p3668-0000-p3509-0000.dtb
INITRD /boot/initrd
APPEND ${cbootargs}

I have tried multiple work-arounds:
1). creating a ./rootfs/boot/dtb folder, as it was not there.
copied the /kernel_tegra194-p3668-0000-p3509-0000.dtb into ./rootfs/boot/dtb file.

2). modify extlinux.conf as per below;
FDT /boot/kernel_tegra194-p3668-0000-p3509-0000.dtb

Either way does not work.

If some one can advice me what is going wrong at my side, I would greatly appreciate it.

Thank you.
Mei Guodong

Hi meiguodong,

Are you using the devkit or custom board for Xavier NX?
What’s your Jetpack version in use?

To configuring the pinmux for pin state, you don’t need to build kernel image and dtb.
Please revert the kernel image and dtb, then just update with the generated .cfg files.

Are you flashing the SD card on the devkit with this command?
Have you tried to use mmcblk0p1 instead of internal?

$ sudo ./flash.sh jetson-xavier-nx-devkit mmcblk0p1

Hi Kevin,

I am using NX dev kit. JetPack version 35.1.1 .

I have found the issue the system does not boot up. the issue was I shall not include the xxx-pinmux.dtsi in the main dts file before building the kernel. otherwise, it will not boot up.

Just would like to confirm that after set in the excel sheet for the pinmux, and covnert to the .cfg, copy to the …/BCT/ folder, I can go direct to flash the image?

This is different to what is discussed in the forum. Some other posts say I need to include the xxx-gpio.dtsi file in main dts, and then re-build the kernel image and kernel dtb.

Please confirm.
Thank you.
Mei Guodong

Yes, correct!

That workflow is for Orin series platform(T234).
However, what you are using is Xavier NX (T194).

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.